Highlighted

ColdFusion 2016 / 2018 and Amazon S3

New Here ,
Aug 24, 2018

Copy link to clipboard

Copied

Hello everyone,

Does anyone know if ColdFusion 2018 has an updated connection to Amazon AWS S3? I am getting this error from ColdFusion 2016: "The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256."

This happens for newer regions since Amazon updated their encryption for any S3 regions added after 2014.


Thank you for any help you can provide!

Unfortunately, ColdFusion 2018 does not natively support v4 signing, which is required for regions added after September, 2014. Please request this feature on the Adobe bug tracker, and it may be addressed in a future release.

You can use the AWS Java SDK, which has v4 signing built in. I'm writing a series on using the AWS Java SDK from ColdFusion, and there is an entry on the basic steps you need to go through to use the AWS Java SDK from within CF.

Views

788

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 2016 / 2018 and Amazon S3

New Here ,
Aug 24, 2018

Copy link to clipboard

Copied

Hello everyone,

Does anyone know if ColdFusion 2018 has an updated connection to Amazon AWS S3? I am getting this error from ColdFusion 2016: "The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256."

This happens for newer regions since Amazon updated their encryption for any S3 regions added after 2014.


Thank you for any help you can provide!

Unfortunately, ColdFusion 2018 does not natively support v4 signing, which is required for regions added after September, 2014. Please request this feature on the Adobe bug tracker, and it may be addressed in a future release.

You can use the AWS Java SDK, which has v4 signing built in. I'm writing a series on using the AWS Java SDK from ColdFusion, and there is an entry on the basic steps you need to go through to use the AWS Java SDK from within CF.

Views

789

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 24, 2018 0
Explorer ,
Aug 29, 2018

Copy link to clipboard

Copied

Unfortunately, ColdFusion 2018 does not natively support v4 signing, which is required for regions added after September, 2014. Please request this feature on the Adobe bug tracker, and it may be addressed in a future release.

You can use the AWS Java SDK, which has v4 signing built in. I'm writing a series on using the AWS Java SDK from ColdFusion, and there is an entry on the basic steps you need to go through to use the AWS Java SDK from within CF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0