ColdFusion 2016 and My SQL 8

New Here ,
May 16, 2021 May 16, 2021

Copy link to clipboard

Copied

I am using Coldfusion 2016 and Mysql 5.7 . I want upgrade to  Mysql 8,according to coldfusion document they mention it support 5.7. Can anyone suggest way to use Mysql 8 

Views

156

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

  1. Stop ColdFusion.
  2. Open ColdFusion's /lib/ directory. Locate any Jar file of the form mysql-connector-java-*.*.*.jar, where *.*.* represents a version number, and delete it.
  3. Go to the MySQL Connector/J download site: https://dev.mysql.com/downloads/connector/j/ 
  4. In "Select Operating System:", choose the option "Platform Independent". The current version is 8.0.25.
  5. Click to download the "Platform Independent (Architecture Independent), ZIP Archive". Click on "No thanks, just start my download."
  6. Unpack the Zip file. You will find that the folder contains the file mysql-connector-java-8.0.25.jar. That is the driver you want.
  7. Copy the JAR file to the /lib/ directory of your ColdFusion installation.
  8. Restart ColdFusion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Did that help? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 20, 2021 May 20, 2021

Copy link to clipboard

Copied

Thank you support , I try next week . In between I need to known when the add the datasource  driver I have to select to "Others" is it? 

My other datasource driver are Mysql 5 . It will work without changing the driver type or  I have to change to" Others ".

(I am not familar with the driver)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Hi @defaultne3mldqroexz , It's OK.

To be clear, I am not a member of  Adobe Support. I am just a ColdFusion developer like you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

quote

...I need to known when the add the datasource  driver I have to select to "Others" is it? 

My other datasource driver are Mysql 5 . It will work without changing the driver type or  I have to change to" Others ".

(I am not familar with the driver)


By @defaultne3mldqroexz

 

Choose "MySQL" as driver.

dsn1.png

 

dsn2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Thank you, I will try

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

LATEST

Hi @defaultne3mldqroexz ,

Is it working now?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I nees a cold fusion developer are you available? What is your rate?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines