Highlighted

ColdFusion 2016 in IIS 10: HTTP Error 404.17 - Not Found

New Here ,
Jan 02, 2018

Copy link to clipboard

Copied

I have installed ColdFusion 2016 in IIS 10 and when I browse to http://localhost/mysite/ I get HTTP Error 404.17 - Not Found but when I browse to http://localhost/mysite/index.cfm it works just fine. It seems there is some confusion about the default documents being served as static files rather than dynamic files. This is supported by reading further details in the IIS error message:

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.

Most likely causes:

  • The request matched a wildcard mime map. The request is mapped to the static file handler. If there were different pre-conditions, the request will map to a different handler.

Things you can try:

  • If you want to serve this content as a static file, add an explicit MIME map.

Detailed Error Information:

Module   StaticFileModule
Notification   ExecuteRequestHandler
Handler   StaticFile
Error Code   0x80070032

Requested URL   http://localhost:80/mysite/index.cfm
Physical Path   C:\inetpub\wwwroot\mysite\index.cfm
Logon Method   Anonymous
Logon User   Anonymous

It seems that IIS knows that I want to serve index.cfm as the default document, but it's treating it as a static file rather than a dynamic file. Wondering if anyone has any ideas on how to fix this? Thanks.

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 2016 in IIS 10: HTTP Error 404.17 - Not Found

New Here ,
Jan 02, 2018

Copy link to clipboard

Copied

I have installed ColdFusion 2016 in IIS 10 and when I browse to http://localhost/mysite/ I get HTTP Error 404.17 - Not Found but when I browse to http://localhost/mysite/index.cfm it works just fine. It seems there is some confusion about the default documents being served as static files rather than dynamic files. This is supported by reading further details in the IIS error message:

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.

Most likely causes:

  • The request matched a wildcard mime map. The request is mapped to the static file handler. If there were different pre-conditions, the request will map to a different handler.

Things you can try:

  • If you want to serve this content as a static file, add an explicit MIME map.

Detailed Error Information:

Module   StaticFileModule
Notification   ExecuteRequestHandler
Handler   StaticFile
Error Code   0x80070032

Requested URL   http://localhost:80/mysite/index.cfm
Physical Path   C:\inetpub\wwwroot\mysite\index.cfm
Logon Method   Anonymous
Logon User   Anonymous

It seems that IIS knows that I want to serve index.cfm as the default document, but it's treating it as a static file rather than a dynamic file. Wondering if anyone has any ideas on how to fix this? Thanks.

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 02, 2018 0
Adobe Employee ,
Jan 09, 2018

Copy link to clipboard

Copied

Hi,

Can you please check the default document and check what it set there. Also, remove the connector and add the individual connector for that specific website and then run the index page.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2018 0
New Here ,
Jan 12, 2018

Copy link to clipboard

Copied

Thanks for your response Priyank. The default document setting is below:

index.cfm

default.cfm

index.php

Default.htm

Default.asp

index.htm

index.html

iistart.htm

default.aspx

Regarding your suggestion to remove the connector and add it again, I used the ColdFusion 2016 setup program to install the IIS connector, so are you suggesting that I use the Web Server Configuration Tool to remove ColdFusion from IIS and then add it again?

Just to be clear, ColdFusion is working fine if I specifically browse to http://localhost/mysite/index.cfm, it's just that if I browse to http://localhost/mysite/ that it thinks the index.cfm page is static content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 12, 2018 0
New Here ,
Feb 05, 2018

Copy link to clipboard

Copied

Hello Priyank. I appreciate your previous reply. I'm wondering if you have any other suggestions for me?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2018 0
Adobe Employee ,
Feb 05, 2018

Copy link to clipboard

Copied

Hi,

Can you please remove all the connectors and create the connector with individual sites and then try.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2018 0
New Here ,
Feb 19, 2018

Copy link to clipboard

Copied

Hi Priyank. Unfortunately that did not fix the problem. Any other ideas? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2018 0
Adobe Community Professional ,
Feb 19, 2018

Copy link to clipboard

Copied

Uninstall all connectors. Reinstall them, making sure you run the web server configuration tool as administrator. After installing, check each site in the IIS Management Console and see whether the CF IIS Handler Mappings for each site actually point to the right site number - each IIS site has its own number and each web server configuration will have a corresponding directory. Also, make sure each IIS site has a /jakarta virtual mapping in IIS.

Dave Watts, CTO, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2018 0
iq11 LATEST
Explorer ,
Feb 08, 2019

Copy link to clipboard

Copied

Hello,

I am also having the same issue, I have followed all the instructions mentioned here but continue to get the same error, Any suggestions on how to resolve this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0