ColdFusion (2016 release) Update 14

Explorer ,
Feb 27, 2021 Feb 27, 2021

Copy link to clipboard

Copied

Hi all

i dont understand what the Adobe help mean 

 

where i get the secret für the connector...Server.XML and Properties? In i Start the Shell update connector Script in coldfusion ... error 

 

the Problem is i Need the Update because i Need the "Samesite Attribut 

 

i have ubuntu and apache2 and coldfusion 2016 

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Mar 12, 2021 Mar 12, 2021
i resolve the problem:at first update 14....Now the system crash.....go in the shell,/opt/coldfusion2016/cfusion/runtime/binand start ./wsconfig -upgrade after thar edit:/opt/coldfusion2016/cfusion/runtime/conf/server.xml<Connector connectionTimeout="60000" maxThreads="500" port="8016" packetSize="65535" protocol="AJP/1.3" redirectPort="8500" secret="XXXXXXXXX" tomcatAuthentication="false" address="127.0.0.1" />Normal is the coldfusion Port on 8500 Look at the redirectPort. After my update the p...

Likes

Translate

Translate
Adobe Community Professional ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

What version of ColdFusion do you currently have? On which Java version does it run? You may use the following code to find out:

<cfoutput>	
	CF Version: #server.coldfusion.productversion# <br>
	Java Version: #server.system.properties.java.runtime.version#
</cfoutput>

 

Do I understand correctly that you wish to update? If so, have you followed the instructions for installing ColdFusion 2016 Update 14?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

I dont understand complete the introduction...

i have the server.xml (there is the key inside) i have the worker.properties in Coldfusion there is the key inside.

but i dont have under apache/conf any file with properties..

 

The problem is, i have update it via administrator page. and now the server is down. in cause of that i cannot resolve your output

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied


Hello,

 

Since update the CFadmin page still works but the webserver pages don't? If so have you run WSCONFIG and "upgrade" the connector?

 

Here is a sample of my "server" and "workers" files with edits to hide for you to compare with what you have:

 

server.xml:

-- begin connector ---->
Connector port="8018" redirectPort="8451" protocol="AJP/1.3" connectionTimeout="60000" tomcatAuthentication="false" secret="hidden-secret-9A8D-7E09C56D8FD0" packetSize="65535" maxThreads="500" address="127.0.0.1"/>
-- end connector ---->


workers.properties:

worker.cfusion.type=ajp13
worker.cfusion.host=localhost
worker.cfusion.port=8018
worker.cfusion.connection_pool_size=500
worker.cfusion.connection_pool_timeout=60
worker.cfusion.secret=hidden-secret-9A8D-7E09C56D8FD0

 

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Hi Carl,

both files are corect in my configuration.

 

Bit the website is not available... and the admin page is not available...

 

******

/opt/coldfusion2016/cfusion/bin/coldfusion start
ColdFusion 2016 server is already running
exiting

*****

/opt/coldfusion2016/cfusion/bin/coldfusion status
This account is currently not available.

********

 

The server.xml and workers.properties are correct...

 

Regards, Thorsten

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

@tims4831424 

Some questions:

  1. What is the update level of your ColdFusion 2016 installation?
  2. Did you follow the configuration instructions in https://helpx.adobe.com/coldfusion/kb/coldfusion-2018-update-8.html ?
  3. What do you get when you open the following URLs in the browser: http://127.0.0.1:8500,  http://127.0.0.1:80?

 

Some remarks:

  1. Apparently, you were trying to start the ColdFusion server while it was already running. If you wish to restart, you will first have to stop ColdFusion. 
  2.  Make sure the location of the properties file is: {APACHE_HOME}/conf/workers.properties.
  3. Experiment by replacing worker.cfusion.host=localhost with worker.cfusion.host=127.0.0.1

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Tim, I realize you're likely in a panic for things being down, but we need a lot more info to help you.

 

For example, you say the cf admin doesn't work. That could mean you had an error in applying the update. Did you check the logs for the update, in hf-updates?

 

And do you access the cf admin via the builtin web server (like port 8500)? Or without a port, which means it goes through apache? If the latter (which is not supported by default in cf2016 and up), then yes as long as there are problems with the wsconfig, then ALL sites could be down until you fix things.

 

As for that, have you read the entire page that you linked to? There are many troubleshooting steps at the bottom, as that update introduced important new tomcat security fixes that can break your site until properly configured.

 

And did you run the wsconfog tool, to do the upgrade? You mention seeing the secret, but you  or someone you could have put that there manually. That's only one thing the update 14 wsconfig upgrade would do. It would also update the mod_jk.so. And it would add an address attribute to the ajp connector in the server.xml. That has to be correct, or you will get errors. There can also be errors from sites due to headers being sent from apache to tomcat/cf, that may need to be accommodated. 

 

You have not clarified what errors you get, or what logs you've considered. The mod_jk.log in particular could help with the address or header issues. 

 

Again, the technote offers more, and I have blog posts offering still more.

 

But when you're in the state you are, you may not want to go chasing rabbits. If you just want the problem solved, I can help directly and immediately. See carehart.org/consulting. And while my online calendar there won't offer slots for 2 more hours, I can help now if you reach out via the support contacts there. (I may not see a reply here for a while, so please don't leave it at that.) I doubt we'd need more than 15, mins to solve things. Maybe an hour if someone dug a hole we need to repair. 

 

But if you prefer to slog it out online without urgency, we're here to help. Carl's a great rssource, as are others who may join in. 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

I see I missed that BKBK was first to answer. Didn't mean to leave him out in my last comment. Just that I'm reading on a phone and I just missed that in taking it all in and offering that reply. 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Tims, did you ever resolve things? If not, did you have any thoughts in reply to comments since your last reply?


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

LATEST

i resolve the problem:

at first update 14....

Now the system crash.....

go in the shell,

/opt/coldfusion2016/cfusion/runtime/bin

and start ./wsconfig -upgrade

 

after thar edit:

/opt/coldfusion2016/cfusion/runtime/conf/server.xml

<Connector connectionTimeout="60000" maxThreads="500" port="8016" packetSize="65535" protocol="AJP/1.3" redirectPort="8500" secret="XXXXXXXXX" tomcatAuthentication="false" address="127.0.0.1" />

Normal is the coldfusion Port on 8500 Look at the redirectPort. After my update the port was wrong....

Notice the secret and put in the address="127.0.0.1"

 

now go to

/opt/coldfusion2016/config/wsconfig/1/workers.properties

The line is important:

worker.cfusion.host=127.0.0.1
worker.cfusion.secret=XXXXXXXXX

 

after that i copy the file to /etc/apache2

 

restart Apache

start Coldfusion

All runs

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines