Highlighted

ColdFusion 2018 - Not able to select IIS Web Server.

New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

During installation of CF2018 on windows 2019, I'm not getting option to select IIS as web user. In-Built web server is being used.  Anyone had this same issue?

TOPICS
Connector

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 2018 - Not able to select IIS Web Server.

New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

During installation of CF2018 on windows 2019, I'm not getting option to select IIS as web user. In-Built web server is being used.  Anyone had this same issue?

TOPICS
Connector

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 15, 2019 0
Adobe Employee ,
Feb 15, 2019

Copy link to clipboard

Copied

Hi,

With ColdFusion 2018, this is no longer available. You can install it with built-in port and then create the connector using wsconfig utility post installation.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 2
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

Thanks Priyank. Can you please provide some steps to change this to use IIS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Community Professional ,
Feb 15, 2019

Copy link to clipboard

Copied

You can't change this. This is an improvement in CF 2018. This prevents the installation from failing because of some weird problem with IIS, and it gives you a more secure environment. You can simply use the Web Server Configuration Tool after the install has been completed.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 1
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

i used this utility to run all sites on IIS but still CF Admin site is running on local webserver. What was the reason for Adobe to remove to select IIS option? 

Please provide instructions to use only IIS server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Employee ,
Feb 15, 2019

Copy link to clipboard

Copied

Hi,

Once the ColdFusion 2018 installed successfully. Go to \ColdFusion2018\cfusion\runtime\bin and Right click on wsconfig.exe and Run As Admin.

You can select Individual website or Individual All or All with IIS. In my screenshot, things are grayed out because all my website are configured. You won't see things grayed out until and unless you have not configured IIS in your server.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 2
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

No change still it is using local web server after running that utility has admin.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

Thanks Dave. Looks like it is going to be rough when moving our sites from cf11 o cf2018. I'm just stuck on trying to use IIS webserver.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Employee ,
Feb 15, 2019

Copy link to clipboard

Copied

Hi,

That is fine, you can just launch the tool as Admin and create the connector. It will work. Make sure you remove the old connector and then use this utility to create the connector.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

i deleted and then recreated but still does't work. Can you provide some step by step guide to fix this? it is wasting lot of time. Adobe should have taken feedback before implementing this change.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Employee ,
Feb 15, 2019

Copy link to clipboard

Copied

Can you post some screenshot of the error which you are seeing?

This change is good because if someone has a connector already done with IIS and we create the connector during installation. It will make duplicate entries and sometimes we have to remove these manually which takes more time.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

There is no error, the cf admin is running with built in server and turned IIS default site. I just want cf admin to run on IIS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
Adobe Employee ,
Feb 15, 2019

Copy link to clipboard

Copied

Hi,

This requires manual steps and every time you re-create the connector, you have to replace the uriworkermap.properties. This change is for security reason we removed this feature from ColdFusion 2016 onwards.

Here are the steps. Though, it is not recommended.

1. As you have already created the connector with IIS Default web site.

2. Right click on the Default Website>Add Virtual Directory>Alias is "CFIDE" and path is "\ColdFusion2018\cfusion\wwwroot\CFIDE" and click Ok

3. Go to \ColdFusion2018\config\wsconfig\1, open uriworkermap.properties and uncomment the !/CFIDE/* = cfusion to "/CFIDE/* = cfusion" and Save the Changes. Screenshot.

   

              

4. Restart the IIS and try to access the CF Admin from IIS. http://{hostname}/CFIDE/administrator/index.cfm

5. You have to disable the internal web server port.

6. Go to \ColdFusion2018\cfusion\runtime\conf and take the backup of server.xml.

7. Open the server.xml and search for "internal web server start" and then comment on this entry, check the screenshot.

    

8. Restart ColdFusion service.

Hope this helps.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
ah_dc LATEST
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

Thanks Priyank for providing detailed instructions. Let me try that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0