ColdFusion 2018 Scheduler issue

New Here ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

The ColdFusion Scheduler works for scheduled jobs, but when manually triggering a job for the first time each day from the ColdFusion Scheduler screen in ColdFusion administrator, the job appears to run successfully.  There are no application log entries with errors and the scheduler log indicates the job was manually triggered.

 

The problem is... the job doesn't really run until I manually trigger it a second time.  Subsequent jobs run when manually triggered from the same screen until the next day by which

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

... I have to repeat the process (manually trigger the second time to get the jobs to start successfully triggering manually).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

Assuming there is nothing amiss about the time, date, repeat values, crontime, etc for the job, I would confirm that what you experience should NOT happen. But there should be an explanation and solution, also.

 

As for understanding and resolving the problem, there are lots of potential variables at play: first what update level of CF are you on in your CF2018 (the latest is update 10)? Did any of those updates experience an errror

 

As for the tasks you refer to, did you create them anew in CF2018?  Or were they imported from an earlier version, such as during an auto-import migration (where the earlier CF version was on the same machine) or a CAR migration (which can be done from the same or another machine)? Even if you don't know for sure, you can see a log of either type in the CF logs folder, which may have been weeks, months, or years ago. It will identify tasks that were imported.

 

It's worth knowing if they were imported, either way. Sometimes, when things are imported, there may be some problem in the underlying XML created for the task (in the neo-cron.xml file, in the lib folder of your instance, such as cfusion/lib). Worse, sometimes people try to shortcut things by just copying the neo-cron.xml from one verison to another, which is almost always a bad idea.

 

As a workaround/test, have you tried creating a new task, from scratch, even with all the same values? If so, does THAT cause the same problem?

 

If it does NOT, then that would suggest there WAS indeed some problem with the other task.  If you wanted, you could then do a comparison of the XML (with the right tools) to perhap find what was different. If you have many, I realize that may seem daunting. I could help do that comparison on a consulting basis, pretty quickly (perhaps minutes). Or you may opt just to create new tasks, and call it a day.

 

Let us know what you think or might say in response to any of the above. Hope it may help.


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Charlie,

 

Thank you for taking a look at this.  I am running update 10.  I was mistaken initial post in that scheduler.log is showing signs of the problem. 

 

The scheduled tasks were all newly-created and then re-created.  It doesn't matter which paused task I try to manually trigger via the scheduler in CF administrator.  The first each day will result in a misfire.

 

Here is the scheduler screen:

20210315scheduler.gif

And then the subsequent log entries:

20210315schedulerLog.gif

The scheduler indicates the manual trigger as a misfire and then we see the 7:06:21AM entry as an error 500.  I can repeat this each day like clockwork.

 

Again, the reason I have these jobs paused is I'm waiting on someone else to provide automated functionality resulting in the data sets these jobs work with which they have yet to put into place.  This is why I am pausing these jobs, manually creating the datasets and then manually triggering the paused scheduled jobs at this time.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

I would recommend you look in the other cf logs for the explanation of the 500 error (coldfusion-out.log, coldfusion-error.log, exception.log). That may help explain both the error and the odd situation. Let us know what you find.

 

Also, you didn't respond to my question about whether there had been any error in updating cf. See the link I pointed to. 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

LATEST

Charlie,

There was no entry in the coldfusion-error.log more recent than March 6, 2021 and those entries within did not correspond to the scheduled jobs/scheduler.  All other entries included in the images are from today (2021/03/15) and seemingly correspond to one another.

 

I found the following entry in the coldfusion-out.log at the same time:

20210315cfoutlog.gif

Also, I found the following in exception.log:

20210315cfexceptionlog.gif

I did not experience errors during the update process (cf2018 update 10 log):

20210315cfUpdate10Log.gif

Thanks again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines