coldfusion 2018 service exits immediately

New Here ,
Sep 30, 2019 Sep 30, 2019

Copy link to clipboard

Copied

I have installed cold fusion 2018 on CentOS7, as Server Configuration (Production Profile + Secure Profile) with default Sub-components and servlets, using default install dir, and default Built-In Web Server Port. 

 

I followed this guide here, installing on a fresh new clean server / instance of linux.

https://www.adobe.com/content/dam/acom/en/products/coldfusion/pdfs/coldfusion-2018-lockdown-guide.pd...

 

When I got to section 5.4 I could not get the SSH tunnel to work.

 

When I run the following command:

[root@server ~]# systemctl status cf2018.service -l

 I get the following result:

● cf2018.service - Adobe ColdFusion 2018
   Loaded: loaded (/etc/systemd/system/cf2018.service; enabled; vendor preset: disabled)
   Active: active (exited) since Mon 2019-09-30 10:12:16 HKT; 1 day 4h ago
 Main PID: 2285 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/cf2018.service

Sep 30 10:12:16 server.ewc-asia.com systemd[1]: Started Adobe ColdFusion 2018.
Sep 30 10:12:16 server.ewc-asia.com bash[2285]: Usage:/opt/coldfusion2018/cfusion/bin/sysinit (start|stop|restart|status|wsconfig)

 I can't figure out why the service is "exited".

 

After a lot of confusion and looking around I tried this:

[root@server bin]# ./findjava.sh
./findjava.sh: line 35: [: 110 2018-10-16 LTS: integer expression expected
../../jre/bin/java is not a supported version of Java. Set JAVA_HOME environment variable to 1.7 or later.

However, it looks like I'm using the correct version:

[root@server jre]# /usr/lib/jvm/jre/bin/java --version
openjdk 11.0.4 2019-07-16 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.4+11-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.4+11-LTS, mixed mode, sharing)

I've tried different versions in /opt/coldfusion2018/cfusion/bin/jvm.config and but was not successful.

 

Any idea what might be going on, or how I can get more detail?

 

Thanks

Views

62

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation