Highlighted

ColdFusion 9.0.2 with IIS 7.5, Windows 2008 R2 Failure

Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi,

I am trying to fresh install ColdFusion 9.0.2 on IIS7.5 ( Windows 2008 R2 ).

Options : Enterprise Multiserver configuration.

After install, when  I open CFIDE/administrator or any CF page its throwing error as below :

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Thanks.

Issue is Resolved just need to install ASP.NET module in IIS.

Server-500Error.png

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 9.0.2 with IIS 7.5, Windows 2008 R2 Failure

Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi,

I am trying to fresh install ColdFusion 9.0.2 on IIS7.5 ( Windows 2008 R2 ).

Options : Enterprise Multiserver configuration.

After install, when  I open CFIDE/administrator or any CF page its throwing error as below :

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Thanks.

Issue is Resolved just need to install ASP.NET module in IIS.

Server-500Error.png

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Paul,

When you run ColdFusion9\runtime\bin\wsconfig.exe does it show
CF9 connected to IIS? Pictured.

Capture.JPG

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Carl,

First Thank you very much for your prompt solution.

It was empty. I have added the connection as required. And now its throwing 500.0 Error as below.

Please help me.

Server-500Error.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Paul,

I think IIS does not have ISAPI feature. Suggest:
run WSCONFIG and remove CF IIS connection
Add IIS features in Application Development pictured
run WSCONFIG and add CF IIS connection

Capture.JPG


HTH again, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Carl,

Isapi Module is already installed, below is the screenshot,

Let me know. If we need to add more thing :

Server-500Error.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

CF9 IIS, it has been a while for me. Something nags me about IIS6 compatibility pictured.

Capture.JPG

Perhaps while you are there add ASP and CGI - just in case. You could take those away case I have over guessed latter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Carl,

Yes, that I have already enabled and also as it is 64bit. I have enable 32bit in Default Application pool.

Below are the screenshot :

Server-500Error.png

DefaultAppPool.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

I don't know.

Did you mean CF9 is 32 bit and Windows 2008 r2 is 64 bit?

Wonder if there is anything helpful in the CF9 IIS connector log? Here ColdFusion9\runtime\lib\wsconfig\1\LogFiles

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Carl,

No folder like that. As we installed as Multiserver, so its started like E:\Jrun4\

And also no log file under : E:\JRun4\lib\wsconfig\1 \    location.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Paul,

Beg my pardon Jrun4\bin\WSCONFIG I should have referenced before.

I just went and looked at one. JRun4\lib\wsconfig\1\LogFiles should have some jrun_iis6_wildcardMMYYDD.log files. JRun4\lib\wsconfig\1\ readme.txt might be interesting. the one I see has the IIS connection information, other than that you got DLL INI and store. Paste of TXT case it helps:

This file was created by the JRun Connector Installer.
Do not delete this directory or the files in it because your web server
configuration files contain references to the files in this directory.

web server: IIS
web server version: 7.5
IIS web site: All (0)

Permissions, are you running wsconfig as administrator?

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Explorer ,
Feb 03, 2015

Copy link to clipboard

Copied

Hi Carl,

But there is no store file. I have attached the complete wsconfig folder as zip.

https://drive.google.com/file/d/0B0u53-FLqXA-dy0zMENBeEk4Zjg/view?usp=sharing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 03, 2015

Copy link to clipboard

Copied

For what it is worth that is how the files and folders look except I have LogFiles folder and jrunserver.store in "1". jrunserver.store syntax reads proxyservers=

I have no confidence that just making the folder and file will fix the issue but I guess it is not currently working to serve CFM pages so no harm in trying.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0
Guide ,
Feb 04, 2015

Copy link to clipboard

Copied

I don't think I have any real good idea on this.

Case I missed something. Taskmanager > process tab, shows jrun.exe or jrun.exe*32 ?

Is CF using a built in port? Can CFadmin be browsed ok on the port?

HTH again, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0
Explorer ,
Feb 10, 2015

Copy link to clipboard

Copied

Issue is Resolved just need to install ASP.NET module in IIS.

Server-500Error.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0