Highlighted

Coldfusion administrator is not being served up by iis

New Here ,
Sep 12, 2017

Copy link to clipboard

Copied

I have CF 2016 installed and at one time the CF administrator was working. the sort cut to the CFIDE/administration is does not server up the web page any longer.

CF is working on the server the websites are still running.

my sites are under WWW the coldfusion default is under wwwroot.

IIS default is WWW and does not include wwwroot. I'm guessing that's the problem. but again it did work at one time.

I think the answer may be in IIS? is there someplace I need to look for specific CF configuration in IIS?

Thanks you,

Mike

Hi Mike,

I gather CF2016 CFIDE/administrator not from IIS is by design for security reasons.

If you browse the tomcat port specified durring CF2016 install that should work EG:

http://localhost:8500/CFIDE/administrator/

HTH, Carl.

Views

913

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Coldfusion administrator is not being served up by iis

New Here ,
Sep 12, 2017

Copy link to clipboard

Copied

I have CF 2016 installed and at one time the CF administrator was working. the sort cut to the CFIDE/administration is does not server up the web page any longer.

CF is working on the server the websites are still running.

my sites are under WWW the coldfusion default is under wwwroot.

IIS default is WWW and does not include wwwroot. I'm guessing that's the problem. but again it did work at one time.

I think the answer may be in IIS? is there someplace I need to look for specific CF configuration in IIS?

Thanks you,

Mike

Hi Mike,

I gather CF2016 CFIDE/administrator not from IIS is by design for security reasons.

If you browse the tomcat port specified durring CF2016 install that should work EG:

http://localhost:8500/CFIDE/administrator/

HTH, Carl.

Views

914

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 12, 2017 0
Guide ,
Sep 12, 2017

Copy link to clipboard

Copied

Hi Mike,

I gather CF2016 CFIDE/administrator not from IIS is by design for security reasons.

If you browse the tomcat port specified durring CF2016 install that should work EG:

http://localhost:8500/CFIDE/administrator/

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2017 0
Adobe Community Professional ,
Oct 11, 2017

Copy link to clipboard

Copied

Mike, can you confirm for us if your problem is resolved? It sure sounds like it's just that you didn't realize that CF2016 now FORCES you to use the built-in web server for access to the CF Admin.  You can no longer access it via IIS (or Apache or nginx), for security reasons, as Carl notes.

And not only is it that CF2016 no longer puts a CFIDE virtual directory into your sites in IIS (via the web server config tool or the installer's original integration of CF with IIS), but you will find that if you try to force it there, CF will still reject the attempt, all trying to protect people from leaving their CF admin exposed via external web servers. (Other features and recommendations from the past were just too easily missed by folks, I guess.)

I have assumed for now that this is the issue, and so I have marked Carl's reply as "the answer". You can remove that designation if you feel it is not the answer.

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2017 0