ColdFusion Builder 2016 small icons on high resolution.

Community Beginner ,
May 20, 2017 May 20, 2017

Copy link to clipboard

Copied

I just change my laptop to a new one that has 3200 x 1800 resolution, but when opening CF Builder the tool bars and icons display very small, even the home screen shows very small.

2017-05-20.png

I tried with a lower resolution but the IDE displays the same.

Is there any fix to this?

Thanks.

TOPICS
Builder

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Sep 02, 2017 Sep 02, 2017
The solution is: Open the Registry and navigate to this path Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide, add a new DWORD record named "PreferExternalManifest" with value "1" In the CF builder installation directory (C:\ColdFusionBuilder2016) create a file named CFBuilder.exe.manifest with this content<?xml version="1.0" encoding="UTF-8" standalone="yes"?><assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microso...

Likes

Translate

Translate
Advocate ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Press Ctl+0 (that's a zero) to reset the zoom, or hold down the Ctrl key and move the mouse wheel to change the amount of zoom.

I tested this in CFB3, but it should also work in CFB2016.

Cheers

Eddie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Thanks for your answer Eddie, but that only works for the working area, the zoom does not affect the size of the toolbar and/or the buttons in the right and top of the interface.

I read in another post that this issue comes from eclipse and there is a fix for Eclipse but I think adobe will still need to put hands on it also as I tried but it didn't work.

Solution for Eclipse with High Resolution laptops / Perfecto Mobile Community

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 01, 2017 Jun 01, 2017

Copy link to clipboard

Copied

Sorry, I overlooked your mentioning the toolbar when I looked at your screenshot. Yes, this is a "High DPI awareness" issue that application developers have to explicitly take into account when developing applications for current environments. Unfortunately it looks like Eclipse isn't high DPI aware.

Cheers

Eddie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

It's not even 1980x1020 aware, which has been out for a very long time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2017 Jul 29, 2017

Copy link to clipboard

Copied

It fixes the problem for CFB2016 same as it does for Eclipse, you just need to rename "eclipse.exe.manifest" to "CFBuilder.exe.manifest" and save it in the same folder where your CFBuilder.exe file is located (by default it's under C:\ColdFusionBuilder2016\ folder). It fixed the problem on my laptop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2017 Sep 02, 2017

Copy link to clipboard

Copied

Thanks ilia.ametov,

Yes that fixed the problem, but today I installed the latest windows update 1703 (Creators), and the issue came back again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2017 Sep 02, 2017

Copy link to clipboard

Copied

The solution is:

  1. Open the Registry and navigate to this path Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide, add a new DWORD record named "PreferExternalManifest" with value "1"regedit_LI.jpg
  2. In the CF builder installation directory (C:\ColdFusionBuilder2016) create a file named CFBuilder.exe.manifest with this content

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <description>eclipse</description>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">

        <security>

            <requestedPrivileges>

                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"

                               level="asInvoker"

                               ms_asmv3:uiAccess="false">

                </requestedExecutionLevel>

            </requestedPrivileges>

        </security>

    </trustInfo>

    <asmv3:application>

        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">

            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>

        </asmv3:windowsSettings>

    </asmv3:application>

</assembly>

3. Restart.

*Note: Some windows updates will remove the PreferExternalManifest record from the registry so you only need to add the record again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

So, they charge $200.00 for this program and we have to do Registry Edits to be able to use it.  LoL

I only have 1980x1020 res and I cannot see diddly in this program. 

Not only are the icons/buttons too tiny to have a clue what they are, the actual fonts in the pages I'd like to work on are unreadable.

In the case of the fonts, the size is ok, they're just stippled, faded and unreadable.  Like trying to read in an app from the 1990's.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 24, 2018 Jan 24, 2018

Copy link to clipboard

Copied

This issue comes from Eclipse originally, and CF Builder works on top of Eclipse, they (both Eclipse and Adobe) should be aware of this issue and fix it on the new releases as people are using High resolution screens more and more.

Maybe its time to submit a request to the ColdFusion Builder team if there is not one yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

3 years later and the issue remains.  It's funny how regular eclipse doesn't do this, but the coldfusion builder does.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

Well, there were two other options offered above that were NOT registry tweaks. It's not clear from your note if any of the 3 have workd. Have they? Or are you still seeking a solution? (One was a rather simple change that seemed to explain how the problem would happen with Eclipse and not CFBuilder.)

 

As for why the problem may remain, well, it is indeed sad--more because CFBuilder came out in 2016 and has now reached its end of life 5 years later (support ended in Feb of this year), so there will be no fixes to it. There is of course CFBuilder 2018.

 

Folks really ought to be using that if they are using CFBuilder at all. BTW, there is indeed a FREE edition of CFBuilder: if you don't put in a license before the 60-day trial expires, it reverts to that free "express" edition, losing several featurs (but still keeping by far most of them). Finally, note that if you buy CF, you get a free license of CFBuilder. I cover both those points in a blog post.

 

For any still reading to this point, the far better news (for most) is that CFBuilder 2021 is due to be rewritten to run on the far more popular and open source VSCode IDE. Those who somehow prefer the Eclipse look and feel can still use CFBuilder 2018, which is supported for 2 more years.


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

Forgot to mention that it still happens by default on CF Builder 2018.  The manifest thing seems to fix it fo me at least.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Glad to hear you have solved it, Danny. As for it still happening for you in cfb 2018, are you confirming that was not fixed with any cfb update? 

 

And as for a disappointment in it being in the installer, I have some thoughts it may interest some to consider.

 

First, can you confirm if that was based on your having downloaded and run the installer recently? I ask because sometimes people use older installers.

And I've even seen the downloads in the Adobe licensing site having older installers than were offered on the public Adobe site.

 

I realize you may not know and may not want to reinstall it. If you might want to help future readers, you could look at the install log for cfbuilder, which should be (with a long name, including the date/time installed) in the root of the cfbuilder folder, or its drive root. In that log near the top will be the installer version that ran. 

 

Or if on Windows, you can right-click on the installer exe, choose properties, then details, then see version info.

 

I just share all this as it could be interesting if we may find that different installer versions may have solved this.

 

And since cfb2018 is supported for 2 more years, it still seems important to understand for the sake of any who may yet install it, experience this issue, and perhaps find this thread. 🙂 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Sure thing.  I downloaded and installed it last week.  I have version 3.2.1.0.  I forgot I also had to set it to run in compatibility mode for Windows 8.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Thanks. I'll compare my installers versions when I get to work (writing from my phone). As for the win 8 compat mode, Tha could be significant. Are you running win 8? Or 10? Home or pro? 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Windows 10, 64 bit, Education edition (same as Enterprise without the preinstalled games).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the clarifications, Danny. So first, you say you are on Windows 10 but had run CFB in windows 8 compat mode. You've not clarified why. Is that related to an attempt to deal with the DPI issue, or for some other reason? And I assume that NOT running in Windows 8 compat mode did NOT help the DPI problem?

 

Second, I did confirm that the version of the Windows installer for CFB2018 if downloaded recently is indeed 3.2.1.0. And if installed, it reports in Help>About 3.2.1, and using Help>Check for Updates finds none, so that is indeed the latest CFB.

 

Finally, I'll note that I viewed it on two monitors, with 166 and 177 dpi respectively, which is on the high side as non-Macs go, and I don't see any problem at all. Since you are on Windows as well, I wonder what your DPI is. Do you know already? If not, here's a free online tool to easily report it: https://dpi.lv/ (and there are others). If it's perhaps 200 or more, are you saying it looked as bad as Angel reported in the first screenshot above in 2017?

 

Again, I realize you have implemented the workaround to resolve things, so if you don't want to undo that to confirm things, I understand. In that case, I leave this for others to consider who may come along in the future. But perhaps by then CFB2021 will come out and should surely have no DPI issues--until some future tech doubles or triples what's common. 🙂


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines