Highlighted

ColdFusion Builder 2016 small icons on high resolution.

Community Beginner ,
May 20, 2017

Copy link to clipboard

Copied

I just change my laptop to a new one that has 3200 x 1800 resolution, but when opening CF Builder the tool bars and icons display very small, even the home screen shows very small.

2017-05-20.png

I tried with a lower resolution but the IDE displays the same.

Is there any fix to this?

Thanks.

The solution is:

  1. Open the Registry and navigate to this path Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide, add a new DWORD record named "PreferExternalManifest" with value "1"regedit_LI.jpg
  2. In the CF builder installation directory (C:\ColdFusionBuilder2016) create a file named CFBuilder.exe.manifest with this content

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <description>eclipse</description>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">

        <security>

            <requestedPrivileges>

                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"

                               level="asInvoker"

                               ms_asmv3:uiAccess="false">

                </requestedExecutionLevel>

            </requestedPrivileges>

        </security>

    </trustInfo>

    <asmv3:application>

        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">

            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>

        </asmv3:windowsSettings>

    </asmv3:application>

</assembly>

3. Restart.

*Note: Some windows updates will remove the PreferExternalManifest record from the registry so you only need to add the record again.

TOPICS
Builder

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion Builder 2016 small icons on high resolution.

Community Beginner ,
May 20, 2017

Copy link to clipboard

Copied

I just change my laptop to a new one that has 3200 x 1800 resolution, but when opening CF Builder the tool bars and icons display very small, even the home screen shows very small.

2017-05-20.png

I tried with a lower resolution but the IDE displays the same.

Is there any fix to this?

Thanks.

The solution is:

  1. Open the Registry and navigate to this path Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide, add a new DWORD record named "PreferExternalManifest" with value "1"regedit_LI.jpg
  2. In the CF builder installation directory (C:\ColdFusionBuilder2016) create a file named CFBuilder.exe.manifest with this content

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <description>eclipse</description>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">

        <security>

            <requestedPrivileges>

                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"

                               level="asInvoker"

                               ms_asmv3:uiAccess="false">

                </requestedExecutionLevel>

            </requestedPrivileges>

        </security>

    </trustInfo>

    <asmv3:application>

        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">

            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>

        </asmv3:windowsSettings>

    </asmv3:application>

</assembly>

3. Restart.

*Note: Some windows updates will remove the PreferExternalManifest record from the registry so you only need to add the record again.

TOPICS
Builder

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 20, 2017 0
Advocate ,
May 31, 2017

Copy link to clipboard

Copied

Press Ctl+0 (that's a zero) to reset the zoom, or hold down the Ctrl key and move the mouse wheel to change the amount of zoom.

I tested this in CFB3, but it should also work in CFB2016.

Cheers

Eddie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2017 0
Community Beginner ,
May 31, 2017

Copy link to clipboard

Copied

Thanks for your answer Eddie, but that only works for the working area, the zoom does not affect the size of the toolbar and/or the buttons in the right and top of the interface.

I read in another post that this issue comes from eclipse and there is a fix for Eclipse but I think adobe will still need to put hands on it also as I tried but it didn't work.

Solution for Eclipse with High Resolution laptops / Perfecto Mobile Community

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2017 3
Advocate ,
Jun 01, 2017

Copy link to clipboard

Copied

Sorry, I overlooked your mentioning the toolbar when I looked at your screenshot. Yes, this is a "High DPI awareness" issue that application developers have to explicitly take into account when developing applications for current environments. Unfortunately it looks like Eclipse isn't high DPI aware.

Cheers

Eddie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2017 0
New Here ,
Jul 29, 2017

Copy link to clipboard

Copied

It fixes the problem for CFB2016 same as it does for Eclipse, you just need to rename "eclipse.exe.manifest" to "CFBuilder.exe.manifest" and save it in the same folder where your CFBuilder.exe file is located (by default it's under C:\ColdFusionBuilder2016\ folder). It fixed the problem on my laptop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2017 1
Community Beginner ,
Sep 02, 2017

Copy link to clipboard

Copied

Thanks ilia.ametov,

Yes that fixed the problem, but today I installed the latest windows update 1703 (Creators), and the issue came back again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2017 0
Community Beginner ,
Jan 23, 2018

Copy link to clipboard

Copied

It's not even 1980x1020 aware, which has been out for a very long time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2018 0
Community Beginner ,
Sep 02, 2017

Copy link to clipboard

Copied

The solution is:

  1. Open the Registry and navigate to this path Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide, add a new DWORD record named "PreferExternalManifest" with value "1"regedit_LI.jpg
  2. In the CF builder installation directory (C:\ColdFusionBuilder2016) create a file named CFBuilder.exe.manifest with this content

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <description>eclipse</description>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">

        <security>

            <requestedPrivileges>

                <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"

                               level="asInvoker"

                               ms_asmv3:uiAccess="false">

                </requestedExecutionLevel>

            </requestedPrivileges>

        </security>

    </trustInfo>

    <asmv3:application>

        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">

            <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>

        </asmv3:windowsSettings>

    </asmv3:application>

</assembly>

3. Restart.

*Note: Some windows updates will remove the PreferExternalManifest record from the registry so you only need to add the record again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2017 1
Community Beginner ,
Jan 23, 2018

Copy link to clipboard

Copied

So, they charge $200.00 for this program and we have to do Registry Edits to be able to use it.  LoL

I only have 1980x1020 res and I cannot see diddly in this program. 

Not only are the icons/buttons too tiny to have a clue what they are, the actual fonts in the pages I'd like to work on are unreadable.

In the case of the fonts, the size is ok, they're just stippled, faded and unreadable.  Like trying to read in an app from the 1990's.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2018 0
Community Beginner ,
Jan 24, 2018

Copy link to clipboard

Copied

This issue comes from Eclipse originally, and CF Builder works on top of Eclipse, they (both Eclipse and Adobe) should be aware of this issue and fix it on the new releases as people are using High resolution screens more and more.

Maybe its time to submit a request to the ColdFusion Builder team if there is not one yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 24, 2018 0