Coldfusion builder 2018 fail with cordova and gradle

New Here ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

[Cordova Build] 01/28 at 11:35:37 Executing Command: npm -version
[Cordova Build] 01/28 at 11:35:38 6.13.4
[Cordova Build] 01/28 at 11:35:38 Cordova build is being created under: C:\Users\a\cordova\primero\
[Cordova Build] 01/28 at 11:35:38 Executing Command: cordova -v
[Cordova Build] 01/28 at 11:35:39 9.0.0 (cordova-lib@9.0.1)
[Cordova Build] 01/28 at 11:35:40 Executing Command: cordova build --debug android
[Cordova Build] 01/28 at 11:35:42 Checking Java JDK and Android SDK versions
[Cordova Build] 01/28 at 11:35:42 ANDROID_SDK_ROOT=C:\Users\a\AppData\Local\Android (recommended setting)
[Cordova Build] 01/28 at 11:35:42 ANDROID_HOME=C:\Users\a\AppData\Local\Android (DEPRECATED)
[Cordova Build] 01/28 at 11:35:42 Subproject Path: CordovaLib
[Cordova Build] 01/28 at 11:35:42 Subproject Path: app
[Cordova Build] 01/28 at 11:35:44 Downloading https://services.gradle.org/distributions/gradle-4.10.3-all.zip
[Cordova Build] 01/28 at 11:35:45
[Cordova Build] 01/28 at 11:35:45 Exception in thread "main" javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1937)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1894)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1877)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1398)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1375)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:563)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.jav...)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1512)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Download.downloadInternal(Download.java:67)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Download.download(Download.java:52)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install$1.call(Install.java:62)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install$1.call(Install.java:48)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAccessManager.java:69)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install.createDist(Install.java:48)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:107)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:63)
[Cordova Build] 01/28 at 11:35:45 Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:90)
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.Validator.getInstance(Validator.java:179)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.getValidator(X509TrustManagerImpl.java:312)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkTrustedInit(X509TrustManagerImpl.java:171)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:184)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1460)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:212)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Handshaker.processLoop(Handshaker.java:969)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Handshaker.process_record(Handshaker.java:904)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1050)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1363)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1391)
[Cordova Build] 01/28 at 11:35:45 ... 14 more
[Cordova Build] 01/28 at 11:35:45 Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXParameters.setTrustAnchors(PKIXParameters.java:200)
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXParameters.<init>(PKIXParameters.java:120)
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXBuilderParameters.<init>(PKIXBuilderParameters.java:104)
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:88)
[Cordova Build] 01/28 at 11:35:45 ... 26 more
[Cordova Build] 01/28 at 11:35:45 C:\Users\a\cordova\primero\platforms\android\gradlew: Command failed with exit code 1 Error output:
[Cordova Build] 01/28 at 11:35:45 Exception in thread "main" javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1937)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1894)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1877)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1398)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1375)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:563)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.jav...)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1512)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
[Cordova Build] 01/28 at 11:35:45 at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Download.downloadInternal(Download.java:67)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Download.download(Download.java:52)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install$1.call(Install.java:62)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install$1.call(Install.java:48)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAccessManager.java:69)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.Install.createDist(Install.java:48)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:107)
[Cordova Build] 01/28 at 11:35:45 at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:63)
[Cordova Build] 01/28 at 11:35:45 Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:90)
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.Validator.getInstance(Validator.java:179)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.getValidator(X509TrustManagerImpl.java:312)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkTrustedInit(X509TrustManagerImpl.java:171)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:184)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1460)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:212)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Handshaker.processLoop(Handshaker.java:969)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.Handshaker.process_record(Handshaker.java:904)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1050)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1363)
[Cordova Build] 01/28 at 11:35:45 at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1391)
[Cordova Build] 01/28 at 11:35:45 ... 14 more
[Cordova Build] 01/28 at 11:35:45 Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXParameters.setTrustAnchors(PKIXParameters.java:200)
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXParameters.<init>(PKIXParameters.java:120)
[Cordova Build] 01/28 at 11:35:45 at java.security.cert.PKIXBuilderParameters.<init>(PKIXBuilderParameters.java:104)
[Cordova Build] 01/28 at 11:35:45 at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:88)
[Cordova Build] 01/28 at 11:35:45 ... 26 more
[Cordova Build] 01/28 at 11:35:45 Picked up _JAVA_OPTIONS: -Xmx512M

 

I have installed Android studio that has gradle version 5.4.1 but the CFBuilder 2018 and cordova do not recognize it.

Then install that version of gradle in another directory, if I recognize it but I get the error I sent.

I don't know where it comes from that is looking for version -4.10.3-all of gradle.

I have tried a number of changes but nothing works.

Anyone have any solution.

Thanks

Hector

hblanco@telematicaenlinea.com

TOPICS
Advanced techniques, Builder, Documentation

Views

610

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2020 Jan 29, 2020

Copy link to clipboard

Copied

Thank you for sending the gradle 4, but I already had it and had tried. It didn't work either.

 

Uninstall the CFB 2018 and install the CFB 2016 and thinking I wouldn't have that much trouble. But it also sends error: PhoneGap 3.7.0 not supported

 

In both cases there is no way to configure anything.
There are no clear procedures. Being commercial products, they should have well-defined configuration procedures.

 

Open software is used and an unintelligible mix is made.

 

There are corrections in the configurations but there is no way or how or where.

 

In both cases, cordova and phonegab, there is only one configuration tab that is useless.


Anyone have any idea what to do to make something work in these IDEs?

 

For many years I have used the CF Studio and the CF server and there is always enough help to solve the problems.

 

I think that in the case of mobile applications the CFB is missing a lot.

 

Thanks

Héctor Blanco

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2020 Jan 29, 2020

Copy link to clipboard

Copied

I estimate that we now have about 5 (maybe less) thread of mobile development with Coldfusion in this forum.

 

I did give up mobile development with version 2018. With mobile development you  need to have documentation and a platform serving continuous updates so the Coldfusion 2 years new version policy just do not work anymore at all.

 

Also the upcoming version seems to concentrate to microservices and cli so mobile with Coldfusion is done.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

LATEST

I received an email from Adobe Support Community asking if I had already solved this issue.

 

The answer is no.

 

For the reasons already stated.

 

I would be grateful if someone from the Adobe CFBuilder technical staff had any answers.

 

To make the app use Android Studio, it is difficult work to make the necessary settings but in this case I already achieved it using Firebase. However, this has many options and requires technical hardware and software resources to work. In addition to being tied to this technology. The good thing about this platform is that if you have enough documentation.

 

I hope someday this can be done in the CFBuilder.

 

Thaks

Héctor Blanco

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines