Highlighted

ColdFusion Builder 3 - Search on Open Documents produces java.lang.NullPointerException

Explorer ,
Oct 27, 2014

Copy link to clipboard

Copied

ColdFusion Search Dialog:

Search on Open Documents produces java.lang.NullPointerException

Works well with Search on Current Documents

Paid license.

Please Advice.

TOPICS
Builder

Views

724

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion Builder 3 - Search on Open Documents produces java.lang.NullPointerException

Explorer ,
Oct 27, 2014

Copy link to clipboard

Copied

ColdFusion Search Dialog:

Search on Open Documents produces java.lang.NullPointerException

Works well with Search on Current Documents

Paid license.

Please Advice.

TOPICS
Builder

Views

725

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 27, 2014 0
Nov 28, 2014

Copy link to clipboard

Copied

Can you please paste/add error screenshot for this issue?

Are you getting any error logging for this error there?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2014 0
Explorer ,
Jan 30, 2015

Copy link to clipboard

Copied

Capture1.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2015 0
Adobe Community Professional ,
Feb 01, 2015

Copy link to clipboard

Copied

Could you show us the steps in your search process. I am unable to reproduce your settings when I open the Search menu in my version of Coldfusion Builder 3.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2015 0
Explorer ,
Feb 02, 2015

Copy link to clipboard

Copied

Ctrl+Alt+F>Scope: Open Documents

If this short cut doesn't work for you, look under CF Builder 3 Preferences > Keys > 'ColdFusion Search Dialog'

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2015 0
Adobe Community Professional ,
Feb 04, 2015

Copy link to clipboard

Copied

Thank you, TechFuser. I have experimented by searching on 'Open Documents', but am unable to reproduce the error. However, there indeed seems to be a problem. It failed to work for me either.

Like you, I got a NullPointerException. But that seemed to happen whenever I restarted ColdFusion Builder 3. The details are as follows:

CFBuilder Version: 3.0.0

Build: 292483

Message:

Unhandled event loop exception

Exception Stack Trace:

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)

  at org.eclipse.swt.SWT.error(SWT.java:4397)

  at org.eclipse.swt.SWT.error(SWT.java:4312)

  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)

  at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4145)

  at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3762)

  at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)

  at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

  at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)

  at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)

  at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)

  at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

  at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)

  at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)

  at com.adobe.ide.coldfusion.rcp.intro.Application.start(Unknown Source)

  at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)

  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)

  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

  at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

  at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

  at java.lang.reflect.Method.invoke(Unknown Source)

  at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)

  at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)

  at org.eclipse.equinox.launcher.Main.run(Main.java:1450)

Caused by: java.lang.NullPointerException

  at com.adobe.ide.coldfusion.appcodegeneration.runtime.views.ViewContributionService$1.run(ViewContributionService.java:113)

  at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:164)

  at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:158)

  at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)

  ... 23 more

Session Data:

eclipse.buildId=unknown

java.version=1.7.0_55

java.vendor=Oracle Corporation

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0
Adobe Community Professional ,
Feb 04, 2015

Copy link to clipboard

Copied

I then cleared the error log, opened 2 CFM files in the editor, and performed a search as you had done.

Builder proceeded to search the entire workspace. Even then, it failed to find the search text. When I examined the error log, I found it was populated by a pair of errors, which occurs 72 times. The errors are:

errormsg1.png

errormsg2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0
Adobe Community Professional ,
Feb 04, 2015

Copy link to clipboard

Copied

Please report this as a bug, including a link to this forum page

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0
Explorer ,
Feb 04, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0
BKBK LATEST
Adobe Community Professional ,
Feb 04, 2015

Copy link to clipboard

Copied

Cheers! I have voted for it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2015 0