Highlighted

Coldfusion Server Monitor Error

Community Beginner ,
Sep 06, 2016

Copy link to clipboard

Copied

Hi All,

OS / Redhat Linux 7

CF Version 11,0,07,296330

Tomcat version 7.0.64.0

Java version 1.8.0_25 

I have this strange issue that I am hoping is an easy fix.  Previously when I ran CF9 I was able to get into the Server Monitor without issue.  Back in June we deployed a new server and installed CF11.  Since then, I have not been able to get into the Server Monitor, so I am assuming the issue is related to the way I set up ColdFusion on this new server.

When I click on Launch Server Monitor in the CF Administrator, it launches a new window but displays the following error message:

CF Error.png

I am not sure if it just is looking in the wrong area for the server monitor, or the issue is due with the account used to set up CF.  ColdFusion is currently running as user "nobody"....which I am sure is not the right way to have this configured.  For login information, I have tried using the Administrator account that we log into the CF Admin page with, but have not had any luck.

Any help to get this resolved would be greatly appreciated

Thanks!

Community Beginner
Correct answer by brg3 | Community Beginner

We ended up getting this to work. Turns out port 5500 was blocked at the firewall...ugh.

Thanks!

Views

403

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Coldfusion Server Monitor Error

Community Beginner ,
Sep 06, 2016

Copy link to clipboard

Copied

Hi All,

OS / Redhat Linux 7

CF Version 11,0,07,296330

Tomcat version 7.0.64.0

Java version 1.8.0_25 

I have this strange issue that I am hoping is an easy fix.  Previously when I ran CF9 I was able to get into the Server Monitor without issue.  Back in June we deployed a new server and installed CF11.  Since then, I have not been able to get into the Server Monitor, so I am assuming the issue is related to the way I set up ColdFusion on this new server.

When I click on Launch Server Monitor in the CF Administrator, it launches a new window but displays the following error message:

CF Error.png

I am not sure if it just is looking in the wrong area for the server monitor, or the issue is due with the account used to set up CF.  ColdFusion is currently running as user "nobody"....which I am sure is not the right way to have this configured.  For login information, I have tried using the Administrator account that we log into the CF Admin page with, but have not had any luck.

Any help to get this resolved would be greatly appreciated

Thanks!

Community Beginner
Correct answer by brg3 | Community Beginner

We ended up getting this to work. Turns out port 5500 was blocked at the firewall...ugh.

Thanks!

Views

404

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 06, 2016 0
Adobe Employee ,
Sep 07, 2016

Copy link to clipboard

Copied

Hi Brian,

Are you using any SSL in your environment?

Thanks,

Vikram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2016 0
Community Beginner ,
Sep 07, 2016

Copy link to clipboard

Copied

Hi Vikram,

Yes, the actual coldfusion administrator is behind SSL.  I can log into the coldfusion administrator without issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2016 0
Adobe Employee ,
Sep 07, 2016

Copy link to clipboard

Copied

Hi Brian,

Have you tried changing the Jetty configuration file as mentioned in the below article?

Refer-"For connections using HTTPS protocol" section under Server monitoring:

https://helpx.adobe.com/coldfusion/configuring-administering/using-the-coldfusion-server-monitor.htm...

Thanks,

Vikram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2016 1
Community Beginner ,
Sep 08, 2016

Copy link to clipboard

Copied

Thanks for the reply.  I don't seem to have anything listed under the "Set SSL Connectors" section in my config....I have some settings under Configure a TLS (SSL) Context Factory.  Would I need to uncomment that?

  <!-- =========================================================== -->

  <!-- Set connectors                                              -->

  <!-- =========================================================== -->

  <!-- =========================================================== -->

 

  <!-- =========================================================== -->

  <!-- Http Configuration.                                         -->

  <!-- This is a common configuration instance used by all         -->

  <!-- connectors that can carry HTTP semantics (HTTP, HTTPS, SPDY)-->

  <!-- It configures the non wire protocol aspects of the HTTP     -->

  <!-- semantic.                                                   -->

  <!--                                                             -->

  <!-- This configuration is only defined here and is used by      -->

  <!-- reference from the jetty-http.xml, jetty-https.xml and      -->

  <!-- jetty-spdy.xml configuration files which instantiate the    -->

  <!-- connectors.                                                 -->

  <!--                                                             -->

  <!-- Consult the javadoc of o.e.j.server.HttpConfiguration       -->

  <!-- for all configuration that may be set here.                 -->

  <!-- =========================================================== -->

 

    <New id="httpConfig" class="org.eclipse.jetty.server.HttpConfiguration">

      <Set name="secureScheme">https</Set>

      <Set name="securePort">5050</Set>

      <Set name="outputBufferSize">32768</Set>

      <Set name="requestHeaderSize">8192</Set>

      <Set name="responseHeaderSize">8192</Set>

      <!-- send the server version in the response header? -->

      <Set name="sendServerVersion">true</Set>

      <!-- send the date header in the response header? -->

      <Set name="sendDateHeader">true</Set>

      <Set name="headerCacheSize">512</Set>

      <!-- Uncomment to enable handling of X-Forwarded- style headers

      <Call name="addCustomizer">

        <Arg><New class="org.eclipse.jetty.server.ForwardedRequestCustomizer"/></Arg>

      </Call>

      -->

    </New>

  <!-- Add a HTTP Connector.                                       -->

  <!-- Configure an o.e.j.server.ServerConnector with a single     -->

  <!-- HttpConnectionFactory instance using the common httpConfig  -->

  <!-- instance defined in jetty.xml                               -->

  <!--                                                             -->

  <!-- Consult the javadoc of o.e.j.server.ServerConnector and     -->

  <!-- o.e.j.server.HttpConnectionFactory for all configuration    -->

  <!-- that may be set here.                                       -->

  <!-- =========================================================== -->

  <Call name="addConnector">

    <Arg>

      <New class="org.eclipse.jetty.server.ServerConnector">

        <Arg name="server"><Ref refid="Server"/></Arg>

        <Arg name="executor"></Arg>

        <Arg name="scheduler"></Arg>

        <Arg name="bufferPool"></Arg>

        <Arg type="int" name="acceptors">2</Arg>

        <Arg type="int" name="selectors">-1</Arg>

        <Arg name="factories">

          <Array type="org.eclipse.jetty.server.ConnectionFactory">

            <Item>

              <New class="org.eclipse.jetty.server.HttpConnectionFactory">

                <Arg name="config"><Ref refid="httpConfig" /></Arg>

              </New>

            </Item>

          </Array>

        </Arg>

        <Set name="host">0.0.0.0</Set>

        <Set name="port">5500</Set>

        <Set name="idleTimeout">300000</Set>

      </New>

    </Arg>

  </Call>

   

    <!-- =========================================================== -->

    <!-- Set SSL connectors                                          -->

    <!-- Uncomment it and comment all other addConnectors, in case   -->

    <!-- you want to use https.                                      -->    

    <!-- =========================================================== -->

   

    <!-- ============================================================= -->

    <!-- Configure a TLS (SSL) Context Factory                         -->

    <!-- This configuration must be used in conjunction with jetty.xml -->

    <!-- and either jetty-https.xml or jetty-spdy.xml (but not both)   -->

    <!-- ============================================================= -->

    <!-- <New id="sslContextFactory" class="org.eclipse.jetty.util.ssl.SslContextFactory">

        <Set name="KeyStorePath"><Property name="jetty.home" default="." />/<Property name="jetty.keystore" default="etc/keystore"/></Set>

        <Set name="KeyStorePassword"><Property name="jetty.keystore.password" default="OBF:1vny1zlo1x8e1vnw1vn61x8g1zlu1vn4"/></Set>

        <Set name="KeyManagerPassword"><Property name="jetty.keymanager.password" default="OBF:1u2u1wml1z7s1z7a1wnl1u2g"/></Set>

        <Set name="TrustStorePath"><Property name="jetty.home" default="." />/<Property name="jetty.truststore" default="etc/keystore"/></Set>

        <Set name="TrustStorePassword"><Property name="jetty.truststore.password" default="OBF:1vny1zlo1x8e1vnw1vn61x8g1zlu1vn4"/></Set>

        <Set name="EndpointIdentificationAlgorithm"></Set>

        <Set name="ExcludeCipherSuites">

        <Array type="String">

            <Item>SSL_RSA_WITH_DES_CBC_SHA</Item>

            <Item>SSL_DHE_RSA_WITH_DES_CBC_SHA</Item>

            <Item>SSL_DHE_DSS_WITH_DES_CBC_SHA</Item>

            <Item>SSL_RSA_EXPORT_WITH_RC4_40_MD5</Item>

            <Item>SSL_RSA_EXPORT_WITH_DES40_CBC_SHA</Item>

            <Item>SSL_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA</Item>

            <Item>SSL_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA</Item>

        </Array>

        </Set>-->

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2016 0
Community Beginner ,
Sep 09, 2016

Copy link to clipboard

Copied

We ended up getting this to work. Turns out port 5500 was blocked at the firewall...ugh.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 09, 2016 0
BKBK LATEST
Adobe Community Professional ,
Sep 11, 2016

Copy link to clipboard

Copied

Good for you! Please mark the correct answer. It will surely help someone else in future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2016 0