Highlighted

Coldfusion server stops serving pages when accessed over Chrome for Android

New Here ,
Apr 15, 2016

Copy link to clipboard

Copied

We have apache 2.4 running on a Windows Server 2012, everything works fine except one strange bug:

The server stops serving any pages to users after someone visits any page via Chrome for Android. The visitor on the Android device (only when using Chrome) gets an "connection reset" error, but all users after that are getting blank loading pages until Apache gets restarted. If an user is loading a page on any other device during a restart, the page finishes loading immediately.

It seems that i can't find anything specific in the Apache or CF errorlogs. The only error i'm able to find is in the coldfusion-out.log:

Apr 15, 2016 13:34:43 PM Error [ajp-nio-8016-exec-15] - The request has exceeded the allowable time limit Tag: cfhttp The specific sequence of files included or processed is: C:\projekte\removed\So-funktioniert-es-6.html, line: 98

It does mention a specific file here, but it happens no matter what file or page you try to open. It's a really strange bug and we can't find any solution to it, nor anyone else with the same problem. The server isn't overloaded at all.

Hopefully i was specific enough for someone to point us in the right direction.

Views

243

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Coldfusion server stops serving pages when accessed over Chrome for Android

New Here ,
Apr 15, 2016

Copy link to clipboard

Copied

We have apache 2.4 running on a Windows Server 2012, everything works fine except one strange bug:

The server stops serving any pages to users after someone visits any page via Chrome for Android. The visitor on the Android device (only when using Chrome) gets an "connection reset" error, but all users after that are getting blank loading pages until Apache gets restarted. If an user is loading a page on any other device during a restart, the page finishes loading immediately.

It seems that i can't find anything specific in the Apache or CF errorlogs. The only error i'm able to find is in the coldfusion-out.log:

Apr 15, 2016 13:34:43 PM Error [ajp-nio-8016-exec-15] - The request has exceeded the allowable time limit Tag: cfhttp The specific sequence of files included or processed is: C:\projekte\removed\So-funktioniert-es-6.html, line: 98

It does mention a specific file here, but it happens no matter what file or page you try to open. It's a really strange bug and we can't find any solution to it, nor anyone else with the same problem. The server isn't overloaded at all.

Hopefully i was specific enough for someone to point us in the right direction.

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 15, 2016 0
Advocate ,
Apr 15, 2016

Copy link to clipboard

Copied

What is the cfhttp tag doing on the line mentioned???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2016 0
Most Valuable Participant ,
Apr 15, 2016

Copy link to clipboard

Copied

This question was also asked on StackOverflow: http://stackoverflow.com/questions/36646517/coldfusion-server-stops-rendering-pages-when-accessed-ov...

I'll ask the same question that I asked over there:

That error in the log references an HTML file rather than a CFM. Do you have ColdFusion configured to process html files?



Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2016 0