ColdFusion Splendor mail server verify error

Guide ,
Mar 02, 2014 Mar 02, 2014

Copy link to clipboard

Copied

ColdFusion Splendor admin > Server Settings > Mail

Connection Verification Failed! 

When putting in a valid setting for "Mail Server" and tick "Verify mail server connection", Connection Verification Failed is reported.   

Thanks in advance, Carl.

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Mar 07, 2014 Mar 07, 2014
Hi Carl,That sounds strange. I did a quick search online and found, that adding java.net.preferIPv4Stack=true solves the "java.net.SocketException: Network is unreachable: connect".Hope this helps.Regards,Anit Kumar

Likes

Translate

Translate
Adobe Employee ,
Mar 05, 2014 Mar 05, 2014

Copy link to clipboard

Copied

Hi Carl,

This works for me. Here is my mailsent.log

"Severity","ThreadID","Date","Time","Application","Message"

"Information","scheduler-1","03/05/14","15:16:55",,"C:\ColdFusion11\cfusion\logs\mailsent.log initialized"

"Information","scheduler-1","03/05/14","15:16:55",,"Mail: 'Test Email' From:'cfinstal@adobe.com' To:'cfinstal@adobe.com' was successfully sent using mymailservername"

It verifies the connection for me, successfully as well. Can you try an alternative machine?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 06, 2014 Mar 06, 2014

Copy link to clipboard

Copied

Hi Anit,

I will try another system when I can but it will not be soon. CF9 on same system does email ok. Interesting when I try send email my CF11 mail log says:

"com.sun.mail.util.MailConnectException: Couldn't connect to host, port: 10.0.0.1, 25; timeout 60000;   nested exception is:  java.net.SocketException: Network is unreachable: connect"

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 07, 2014 Mar 07, 2014

Copy link to clipboard

Copied

Hi Carl,

That sounds strange. I did a quick search online and found, that adding java.net.preferIPv4Stack=true solves the "java.net.SocketException: Network is unreachable: connect".

Hope this helps.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 09, 2014 Mar 09, 2014

Copy link to clipboard

Copied

Hi Anit,

Thanks for that. Adding -Djava.net.preferIPv4Stack=true to JVM args resolved matter.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 13, 2018 Jan 13, 2018

Copy link to clipboard

Copied

I see that this is quite an old thread, but I have the same problem when I use CFMAIL to sent SMTP email to Mailgun, the connection is not being made. I see the error in the logs: com.sun.mail.util.MailConnectException: Couldn't connect to host

I tried adding -Djava.net.preferIPv4Stack=true to the JVM arguments and restarting, but it did not fix the issue.

This is on CF2016 (Before I upgraded from CF8 it was working fine), the odd thing is that on a CF2016 developer edition on the dev box the same exact scripts connect and work fine.

Does anybody have any ideas

Thanks

Mark

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2018 Jan 13, 2018

Copy link to clipboard

Copied

It’s helpful that you added the observation about the two different instances, Mark. Given that info, I suspect you probably chose the “Developer profile” on the dev machine, and the “production profile” (or “production + secure” on the prod one. The difference could be there.

But since there are about 20 admin setting differences when the “secure profile” is enabled, rather than slog through those, here’s a perhaps simpler explanation:

Are they both the same update level of CF? And are the two CF instances pointing to the same JVM version?

/charlie


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 14, 2018 Jan 14, 2018

Copy link to clipboard

Copied

LATEST

Hi Charlie,

You are right, both are the same version CF2016, dev version on the dev box, and the production server is also the same CF2016, both updated, and both have the same version of JVM.

I can't remember if I installed with the +SECURE option or not, I ran a few initial test installs to play around with it at first, and I'm not sure if I decided to go with the security version, I THINK I did, I'm not sure if there is a way to tell.

I most apologise though, I thought I had updated this ticket as I did manage to get it working.

The default port on install for the SMTP was 25, I changed it to 587 and it started to work. So port 25 is being blocked. I don't see anything on the firewall (although it was a brief look so maybe I missed something), and I certainly didn't change it, I'm 99.9% sure the previous version of CF was also on port 25.

It's not Mailgun because I can use my dev machine on port 25 to send with no problem.

So this points to something on CF that is blocking port 25, which is not great because it sets up the default port itself with port 25.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines