Highlighted

Coldfusion2016 cursors in Oracle

New Here ,
Oct 17, 2019

Copy link to clipboard

Copied

Currently have Coldfusion 2016 installed on Redhat 6 which connects to Oracle 12c database on

 

Previously we had update v5 install and yesterday using the web console, I appled v6 followed by v11 and then finally v12 on our prodcution system.

 

Within an hour of doing the patch update to v12 it exceeded 300 cursors on the Oracle, something we'd never expericed before. Since it was a key production system we increased the cursor size to 600. However the cursor continued to raise with the DBA have to take drastics action on the Oracle database to provent a crash. 

 

My questions is this normal behavior for the v12 patch to incease the amount of Oracle cursors?

Will there be a v13 to correct this cursor issue?

 

Another thing, I noticed in the process that v8 was not present to be upgraded to as I remember on the development.

 

Views

63

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Coldfusion2016 cursors in Oracle

New Here ,
Oct 17, 2019

Copy link to clipboard

Copied

Currently have Coldfusion 2016 installed on Redhat 6 which connects to Oracle 12c database on

 

Previously we had update v5 install and yesterday using the web console, I appled v6 followed by v11 and then finally v12 on our prodcution system.

 

Within an hour of doing the patch update to v12 it exceeded 300 cursors on the Oracle, something we'd never expericed before. Since it was a key production system we increased the cursor size to 600. However the cursor continued to raise with the DBA have to take drastics action on the Oracle database to provent a crash. 

 

My questions is this normal behavior for the v12 patch to incease the amount of Oracle cursors?

Will there be a v13 to correct this cursor issue?

 

Another thing, I noticed in the process that v8 was not present to be upgraded to as I remember on the development.

 

Views

64

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 17, 2019 0
Adobe Community Professional ,
Oct 17, 2019

Copy link to clipboard

Copied

Fwiw, no, I have not heard of anyone else reporting this. As for u8, it was removed because of a problem with it (in Feb) . As for the issue with u12, did you confirm there were 0 errors in the update log? See:

 

https://coldfusion.adobe.com/2019/03/problems-applying-cf-update-check-first/

 

Finally, did you try unistalling u12, to revert to 11? Or again to revert to 6, or 5? That would confirm if/which of those updates you applied caused the problem. But do check that update log each time to ensure 0 errors.

 

Of course, if you revert back to u5, and the problem remains, then it would seem the problem was not  related to the updates at all, which is a possibility. 

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 17, 2019 0