Highlighted

Configure IIS with both CF10 and Standalone Tomcat Servers

New Here ,
Dec 23, 2016

Copy link to clipboard

Copied

Hi -

Our site formerly ran CF9 and a Standalone Tomcat as application servers for different parts of our application, using IIS as the web server front end. There is a proxy server in front of all of that, too. All of this worked OK.

CF10 has now broken this, as requests to our Tomcat Server result in a 404 Not Found error. The difference, I think, is that CF9 did not use an ISAPI redirect filter, while CF10 does. Adding a Tomcat ISAPI redirect filter results in everything (both CF10 and Standalone Tomcat) receiving a 404.

I have tried adding details to the CF10 uriworkermap.properties and workers.properties files specifying the file suffix to pass to Standalone Tomcat, and which port to listen to for Standalone Tomcat requests. This receives a

Bad Gateway

The proxy server received an invalid response from an upstream server.

error, which I guess is an improvement, but not a fix.

Has anyone else encountered a problem like this? Googling is very difficult, due to the confounding of CF Tomcat and Standalone Tomcat in search terms.

I am running out of ideas, and need any help that anyone can provide.

Thanks,

Ian

Views

382

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Configure IIS with both CF10 and Standalone Tomcat Servers

New Here ,
Dec 23, 2016

Copy link to clipboard

Copied

Hi -

Our site formerly ran CF9 and a Standalone Tomcat as application servers for different parts of our application, using IIS as the web server front end. There is a proxy server in front of all of that, too. All of this worked OK.

CF10 has now broken this, as requests to our Tomcat Server result in a 404 Not Found error. The difference, I think, is that CF9 did not use an ISAPI redirect filter, while CF10 does. Adding a Tomcat ISAPI redirect filter results in everything (both CF10 and Standalone Tomcat) receiving a 404.

I have tried adding details to the CF10 uriworkermap.properties and workers.properties files specifying the file suffix to pass to Standalone Tomcat, and which port to listen to for Standalone Tomcat requests. This receives a

Bad Gateway

The proxy server received an invalid response from an upstream server.

error, which I guess is an improvement, but not a fix.

Has anyone else encountered a problem like this? Googling is very difficult, due to the confounding of CF Tomcat and Standalone Tomcat in search terms.

I am running out of ideas, and need any help that anyone can provide.

Thanks,

Ian

Views

383

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 23, 2016 0

Have something to add?

Join the conversation