Highlighted

Control + O to open a file?

Engaged ,
Sep 19, 2014

Copy link to clipboard

Copied

Every other application on my computer uses Control + O to open a file, how can I get CFBuilder to do the same?

Thanks,

Rich

Most Valuable Participant
Correct answer by Carl_Von_Stetten | Most Valuable Participant

Open the Preferences dialog (from the Window menu).  Type "keys" in the box in the upper left corner of the dialog.  Select "Keys" from the "General" heading in the left-hand pane.

In the box above the listing of commands, type "Open File".  The command listing should filter down to just the "Open File..." entry.  Click on it to select it.  Put the cursor in the "Binding:" box near the bottom of the dialog.  Press Control + O to put the key sequence into the box.  The "When:" should default to "In Windows" which is probably fine.  Click "Apply" and "OK" to close the dialog.  Test it out to see if it works.

-Carl V.

Views

238

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Control + O to open a file?

Engaged ,
Sep 19, 2014

Copy link to clipboard

Copied

Every other application on my computer uses Control + O to open a file, how can I get CFBuilder to do the same?

Thanks,

Rich

Most Valuable Participant
Correct answer by Carl_Von_Stetten | Most Valuable Participant

Open the Preferences dialog (from the Window menu).  Type "keys" in the box in the upper left corner of the dialog.  Select "Keys" from the "General" heading in the left-hand pane.

In the box above the listing of commands, type "Open File".  The command listing should filter down to just the "Open File..." entry.  Click on it to select it.  Put the cursor in the "Binding:" box near the bottom of the dialog.  Press Control + O to put the key sequence into the box.  The "When:" should default to "In Windows" which is probably fine.  Click "Apply" and "OK" to close the dialog.  Test it out to see if it works.

-Carl V.

Views

239

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 19, 2014 0
Most Valuable Participant ,
Sep 19, 2014

Copy link to clipboard

Copied

You can change key assignments through Preferences-->General-->Keys or Preferences-->ColdFusion-->Profiles-->Keys.  Control + O is already mapped to a few commands in specific contexts, but you can override those or specify which contexts you want Control + O to be "Open".  See the "When" pull-down at the bottom of the Keys dialog.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2014 0
Engaged ,
Sep 19, 2014

Copy link to clipboard

Copied

Carl

Thanks for your input.

I'm unable to discover, specifically, how/where to enter the command for "File Open", there is no place to identify/select/enter that action, do you happen to know how?

Again, thanks!

Rich

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2014 0
Most Valuable Participant ,
Sep 19, 2014

Copy link to clipboard

Copied

Open the Preferences dialog (from the Window menu).  Type "keys" in the box in the upper left corner of the dialog.  Select "Keys" from the "General" heading in the left-hand pane.

In the box above the listing of commands, type "Open File".  The command listing should filter down to just the "Open File..." entry.  Click on it to select it.  Put the cursor in the "Binding:" box near the bottom of the dialog.  Press Control + O to put the key sequence into the box.  The "When:" should default to "In Windows" which is probably fine.  Click "Apply" and "OK" to close the dialog.  Test it out to see if it works.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2014 0
Engaged ,
Sep 19, 2014

Copy link to clipboard

Copied

Thanks so much Carl, that worked perfectly!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2014 0