Could not connect to SMTP host

Community Beginner ,
Oct 30, 2014 Oct 30, 2014

Copy link to clipboard

Copied

Hello,

We configured with Coldfusion 10 Tasks that send mail using SES (Amazon) with username and password and validated. We launched the task and will manage coldfusion sending emails every x time processing them. In Coldfusion log we are seeing this error is repeated, albeit that finalment eventually send all emails pending queue, "Error", "scheduler-1", "10/23/14", "15 : 05: 19 ",," javax.mail.MessagingException: Could not connect to SMTP host: email-smtp.us-east-1.amazonaws.com, port: 465, response: -1 " A which may be due to this error? because users have reported to us that do not receive emails.


Regards and thanks for yours answers

Views

2.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2014 Nov 03, 2014

Copy link to clipboard

Copied

Hello José Antonio Chao,

Can you Please confirm the "" has been Enabled in the mail server setting or not ? If it is not Enabled, please click the check box corresponding to "" to enable it. And also before submitting your changes, click the "" to check whether your mail server setting verified successfully or not.

mailServer.png

After submitting your changes if you will get a message "Connection Verification Successful" , then the mail server will work perfectly.

If this fails Please mention all the setting in your mail server setting, so that we can get into the exact issue.

Regards

Himansu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2014 Nov 04, 2014

Copy link to clipboard

Copied

Hello Himansu,

we have enable in mail server setting SSL socket connections to mail server, here you can see our setup after check verify mail  server connections, but issue carry on.

Captura de pantalla 2014-11-04 a la(s) 11.37.36.png

Regads,

José Antonio Chao.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2014 Nov 05, 2014

Copy link to clipboard

Copied

Thanks for the clarification José Antonio Chao,

The setting seems fine for mail sending process.


However, Have you ever tried sending a mail from a cfm page with cfmail tag? Does it work perfectly?


Regards,

Himansu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

Hello Himansu,

yes it works fine send email from cfm page, and will also send emails pending in Spool folder, but we have this message mail.log exactly every minute.

Regards,

José Antonio Chao.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

LATEST

Hello José Antonio Chao,

Though I am not sure about the cause,it seems like the default mail server setting is overwritten in some way. What I an get from here is, there is some scheduled task running in every minute, that tries to send mail. So there might be some code in the page called by the scheduler, which is overwriting the default mail server setting (that is working perfectly). So you are getting "Error", "scheduler-1", "10/23/14", "15 : 05: 19 ",," javax.mail.MessagingException: Could not connect to SMTP host: email-smtp.us-east-1.amazonaws.com, port: 465, response: -1 " in the mail.log file exactly every minute.

Regards,

Himansu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines