Date Formatting

New Here ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

Hi,

I have recently upgraded to CF2021.

I am having an issue with date formatting.

I have the code below.

 & #DateFormat(Now(),'YYYY')#& "_" & #DateFormat(Now(),'MM')# & "_" & #DateFormat(Now(),'DD')
the output is    2021_04_91
 
But it should be 2021_04_01
 
It appears to put a 9 instead of a 0
Would anyone might know what would be causing this?

Views

82

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Apr 01, 2021 Apr 01, 2021
It was a bug. The solution is to add the following flag -Dcoldfusion.datemask.useDasdayofmonth=true to your JVM settings. You can do this in one of 2 ways: via the ColdFusion Administrator. Go to the page Server Settings > Java and JVM. Place the mouse cursor at the end of the contents of the input field JVM Arguments. Press the space bar once, and add the above flag. Press Submit Changes. Restart ColdFusion.via the file /cfusion/bin/jvm.config. Open the file in a text editor. Locate the setti...

Likes

Translate

Translate
Adobe Community Professional , Apr 01, 2021 Apr 01, 2021
Well, to be clear, that is only if you have applied update 1 (from last week). If not, the JVM arg will do no good unless you do also get and implement a special hotfix that was made available to solve this problem (by way of that jvm arg which it enabled and honors). For more, see my blog post from soon after CF2021 was released in November: https://www.carehart.org/blog/client/index.cfm/2020/11/24/breaking_change_in_cf2021_dateformat_D_vs_d 

Likes

Translate

Translate
Adobe Community Professional ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

It was a bug. The solution is to add the following flag

-Dcoldfusion.datemask.useDasdayofmonth=true

to your JVM settings.

 

You can do this in one of 2 ways:

  1. via the ColdFusion Administrator. Go to the page Server Settings > Java and JVM. Place the mouse cursor at the end of the contents of the input field JVM Arguments. Press the space bar once, and add the above flag. Press Submit Changes. Restart ColdFusion.
  2. via the file /cfusion/bin/jvm.config. Open the file in a text editor. Locate the setting that starts with java.args=. The values are on the right-hand-side of the = symbol. Follow the list of values to the very end. Place the mouse cursor there. Press the space bar once, and add the above flag. Save the edited file. Restart ColdFusion.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

Well, to be clear, that is only if you have applied update 1 (from last week). If not, the JVM arg will do no good unless you do also get and implement a special hotfix that was made available to solve this problem (by way of that jvm arg which it enabled and honors). For more, see my blog post from soon after CF2021 was released in November:

 

https://www.carehart.org/blog/client/index.cfm/2020/11/24/breaking_change_in_cf2021_dateformat_D_vs_... 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the help, Problem solved 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines