Highlighted

debugger fails to connect

New Here ,
May 10, 2016

Copy link to clipboard

Copied

Unable to debug coldfusion cfml.

I have done the following setting.

Debugger Port: 7777

-DDEBUGGER_SERVER_PORT=7777.

Test debugger fails.

Correct answer by GonzoRock | Community Beginner

I had the same problem last week. I found a solution here:  Adobe ColdFusion Builder * Using ColdFusion debugger

Solution was to open port 1513 on my desktop so that it could communicate with the debugger running on the ColdFusion server. I used the Windows Firewall to create a rule to open it. Next I had to pin that port so that next time CF starts the random debugging port it picks is NOT random anymore.

TOPICS
Builder

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

debugger fails to connect

New Here ,
May 10, 2016

Copy link to clipboard

Copied

Unable to debug coldfusion cfml.

I have done the following setting.

Debugger Port: 7777

-DDEBUGGER_SERVER_PORT=7777.

Test debugger fails.

Correct answer by GonzoRock | Community Beginner

I had the same problem last week. I found a solution here:  Adobe ColdFusion Builder * Using ColdFusion debugger

Solution was to open port 1513 on my desktop so that it could communicate with the debugger running on the ColdFusion server. I used the Windows Firewall to create a rule to open it. Next I had to pin that port so that next time CF starts the random debugging port it picks is NOT random anymore.

TOPICS
Builder

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 10, 2016 0
Community Beginner ,
May 10, 2016

Copy link to clipboard

Copied

I had the same problem last week. I found a solution here:  Adobe ColdFusion Builder * Using ColdFusion debugger

Solution was to open port 1513 on my desktop so that it could communicate with the debugger running on the ColdFusion server. I used the Windows Firewall to create a rule to open it. Next I had to pin that port so that next time CF starts the random debugging port it picks is NOT random anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 10, 2016 0
New Here ,
May 12, 2016

Copy link to clipboard

Copied

Thanks! I still have the problem.

Even though I have set -DDEBUGGER_SERVER_PORT = 7778, my WAS server logs show another port.  

[5/12/16 14:20:01:438 CDT] 000000b9 SystemOut     O May 12, 2016 14:20:01 PM Information [WebContainer : 0] - ColdFusion debugger is listening at port 31258.

Also I have set this in WAS JVM Debug arguments, but when i launch

-Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=7777

I have setup a general java project and launch a debug remote java application and attach the 7777 socket. The debug not able to connect.

Failed to connect to remote VM. Connection timed out.

org.eclipse.jdi.TimeoutException

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Community Beginner ,
May 12, 2016

Copy link to clipboard

Copied

Your first image above stated that 1513 was the port that the debugger was listening on. That changes every time CF starts. That is the port that is not open. Turn your desktop firewall off and try it. Don't leave the firewall off obviously... but give it a try. If it works then you need to turn firewall on again and create a rule for the port to allow it.

Next you pin the port CF uses. This is NOT the port you see in the CF Admin.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
New Here ,
May 13, 2016

Copy link to clipboard

Copied

Hi,

Can you pls elaborate what you mean pin the port? Can you paste the steps?

Next you pin the port CF uses.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2016 0
Community Beginner ,
May 13, 2016

Copy link to clipboard

Copied

From the first document I linked above in my first reply to your question:

7. The debugger server listens for commands from ColdFusion Builder on a separate port than the one specified in step 3. By default, ColdFusion launches the debugger server with a random available port. This could be a problem if ColdFusion (and hence debugger server) is behind a firewall. Because, the firewall blocks the random port that the debugger is listening.

To prevent this problem, specify a fixed debugger server port number and allow this port in the firewall. To set a fixed debugger server port number, specify the following JVM argument on the Java And JVM page of the ColdFusion Administrator (or the appropriate place for your J2EE Application Server). Replace portNumber with the port that you want to use:

-DDEBUGGER_SERVER_PORT=portNumber

So in CFAdmin you "pin" the port by adding "-DEBUGGER_SERVER_PORT=portNumber" to the argument list on JVM config page of the CFAdmin. 

Only do this AFTER you learn what port ColdFusion debugger is listening on... in your screenshot above CFBuilder reported that it was 1513... and AFTER you are successful after clicking the Test Debugger button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2016 0
New Here ,
May 16, 2016

Copy link to clipboard

Copied

After pining the port by adding, -DEBUGGER_SERVER_PORT=7778 to the websphere server jvm. I can see the logs in my J2EE container

[5/16/16 14:01:43:682 CDT] 000000cf SystemOut     O May 16, 2016 14:01:43 PM Information [WebContainer : 2] - ColdFusion debugger is listening at port 7778.

Test Debugger is not consistent. It says succces. But when i launch the debug configuration, it doesn't break or step into the code.

I tried both ColdFusion project and Java project.

Are there any mappings you have set either in the Windows->Preferences

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2016 0
New Here ,
May 12, 2016

Copy link to clipboard

Copied

are you setting up as a java project? My firewall is off. I created the firewall rule. But still my java project cannot connect to debugger.

I have java calls from the coldfusion server, my project is java project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0