Highlighted

Debugging problems in 2018

New Here ,
Aug 08, 2018

Copy link to clipboard

Copied

I've installed the development version of ACF2018 under Apache 2.4 on Windows 10 and was unable to get debugging window to show up for the localhost (or any others).  The installation profile is 'development' and I have all the usual options checked to turn it on, but no joy, even for a very simple page on localhost.  This always seemed pretty straightforward on prior versions. Did something else change since ACF 10?

I finally got the debugging window to show by removing all the default debugging IP addresses.  However when I try 'Add Current' which adds 127.0.0.1 or put in the actual IP address, I get nothing again.  It had 127.0.0.1 and the IP6 localhost by default (0:0:0:0:0:0:0:1), and that didn't work.  The debugging says CGI.RemoteHost is '::1' which expands to '0:0:0:0:0:0:0:1' when I add it back to the debugging IP addresses.  Nonetheless, that doesn't work either.  I have FusionReactor and usually don't use debugging on a production server, but every once in a while it's the only way to figure out what the problem is.  Being able to restrict the debugging to localhost or a particular address is pretty important.  Any ideas?

Adobe Community Professional
Correct answer by Charlie Arehart | Adobe Community Professional

Adam, the answer here is simple (though Adobe could make it easier): you just need to add the ::1 to the CF debugging IP list. And no, you can't do it in the Admin (currently). You need to manually add it to the neo-debug.xml file for the instance in question (in the [cf]\cfusion\lib folder).

Find the string that will look like this (your ip address values may be different):

<struct type="coldfusion.server.ConfigMap"><var name="iplist"><string>127.0.0.1,0:0:0:0:0:0:0:1</string></var></struct>

And change it to add,::1 after the 0:1. (And if this forum doesn't show that HTML right, just look in the file for the element called iplist, and add ",::1" to whatever is your IP list.)

Then save it and restart CF for that to take effect, and test things then. I would recommend you keep this file open so that if CF doesn't start, you can easily undo what change you added. To be REALLY safe, it would be wise to save off a copy of the file BEFORE editing it, so that worst-case you could restore that file and restart CF.

Let us know how it goes. I've been meaning to blog about this for a while, including opening a feature request (at tracker.adobe.com) to request that they just put this in by default, like they so for the 127.0.0.1,0:0:0:0:0:0:0:1 values.

Views

415

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Debugging problems in 2018

New Here ,
Aug 08, 2018

Copy link to clipboard

Copied

I've installed the development version of ACF2018 under Apache 2.4 on Windows 10 and was unable to get debugging window to show up for the localhost (or any others).  The installation profile is 'development' and I have all the usual options checked to turn it on, but no joy, even for a very simple page on localhost.  This always seemed pretty straightforward on prior versions. Did something else change since ACF 10?

I finally got the debugging window to show by removing all the default debugging IP addresses.  However when I try 'Add Current' which adds 127.0.0.1 or put in the actual IP address, I get nothing again.  It had 127.0.0.1 and the IP6 localhost by default (0:0:0:0:0:0:0:1), and that didn't work.  The debugging says CGI.RemoteHost is '::1' which expands to '0:0:0:0:0:0:0:1' when I add it back to the debugging IP addresses.  Nonetheless, that doesn't work either.  I have FusionReactor and usually don't use debugging on a production server, but every once in a while it's the only way to figure out what the problem is.  Being able to restrict the debugging to localhost or a particular address is pretty important.  Any ideas?

Adobe Community Professional
Correct answer by Charlie Arehart | Adobe Community Professional

Adam, the answer here is simple (though Adobe could make it easier): you just need to add the ::1 to the CF debugging IP list. And no, you can't do it in the Admin (currently). You need to manually add it to the neo-debug.xml file for the instance in question (in the [cf]\cfusion\lib folder).

Find the string that will look like this (your ip address values may be different):

<struct type="coldfusion.server.ConfigMap"><var name="iplist"><string>127.0.0.1,0:0:0:0:0:0:0:1</string></var></struct>

And change it to add,::1 after the 0:1. (And if this forum doesn't show that HTML right, just look in the file for the element called iplist, and add ",::1" to whatever is your IP list.)

Then save it and restart CF for that to take effect, and test things then. I would recommend you keep this file open so that if CF doesn't start, you can easily undo what change you added. To be REALLY safe, it would be wise to save off a copy of the file BEFORE editing it, so that worst-case you could restore that file and restart CF.

Let us know how it goes. I've been meaning to blog about this for a while, including opening a feature request (at tracker.adobe.com) to request that they just put this in by default, like they so for the 127.0.0.1,0:0:0:0:0:0:0:1 values.

Views

416

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 08, 2018 0
Enthusiast ,
Aug 09, 2018

Copy link to clipboard

Copied

Try accessing your site by typing 127.0.0.1 in the address bar instead of localhost -- the localhost hostname may use IPv6 (depending on your OS), whereas if you specify 127.0.0.1 it is an IPv4 address explicitly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2018 0
New Here ,
Aug 09, 2018

Copy link to clipboard

Copied

Pete,

Thanks, that worked but is still kind of a drag:

With Debug IP addresses set to 127.0.0.1 and ::1 (CF automatically expands this  to 0:0:0:0:0:0:0:1)

Using URL http://127.0.0.1 shows the debugging window with CGI.RemoteHost as 127.0.0.1
Using http://localhost does not show the debugging window

With all Debug IP addresses cleared:

Using URL http://127.0.0.1 shows the debugging window with CGI.RemoteHost as 127.0.0.1 as before

Using http://localhost shows the debugging window with CGI.RemoteHost as ::1

I think that CF is comparing the literal strings 0:0:0:0:0:0:0:1 vs ::1 and since they don't match, is withholding the debugging window.  I have IPv6 turned off, but apparently the default Windows loopback uses IPv6 anyway. Still seems like a bug to me, but I can live with it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2018 0
New Here ,
Aug 22, 2018

Copy link to clipboard

Copied

Hi Adam,

I tried disabling IPv6.Details can be found from below links:

How to disable IPv6 on Windows 10 : My Private Network

https://tweaks.com/windows/40099/how-to-properly-disable-ipv6/

When i hit URL: http://localhost shows CGI.RemoteHost as 0:0:0:0:0:0:1 as of which i don't hit the issue.

Is there something else you did while disabling IPv6 that translated CGI.RemoteHost as::1??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2018 0
Adobe Community Professional ,
Aug 22, 2018

Copy link to clipboard

Copied

Like Adam said, disabling IPv6 doesn't turn it off for the loopback adapter, which is what you use to reach your own machine. That's why Pete recommended explicitly using the IPv4 localhost address instead of the localhost name. I thought you might be able to disable that by removing the corresponding entry from your hosts file, but that no longer seems to be used for resolving the name localhost.

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2018 2
New Here ,
Aug 22, 2018

Copy link to clipboard

Copied

Yeah, like Dave, I got nowhere with trying to edit the Windows hosts file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 22, 2018 0
Adobe Community Professional ,
Aug 23, 2018

Copy link to clipboard

Copied

Adam, the answer here is simple (though Adobe could make it easier): you just need to add the ::1 to the CF debugging IP list. And no, you can't do it in the Admin (currently). You need to manually add it to the neo-debug.xml file for the instance in question (in the [cf]\cfusion\lib folder).

Find the string that will look like this (your ip address values may be different):

<struct type="coldfusion.server.ConfigMap"><var name="iplist"><string>127.0.0.1,0:0:0:0:0:0:0:1</string></var></struct>

And change it to add,::1 after the 0:1. (And if this forum doesn't show that HTML right, just look in the file for the element called iplist, and add ",::1" to whatever is your IP list.)

Then save it and restart CF for that to take effect, and test things then. I would recommend you keep this file open so that if CF doesn't start, you can easily undo what change you added. To be REALLY safe, it would be wise to save off a copy of the file BEFORE editing it, so that worst-case you could restore that file and restart CF.

Let us know how it goes. I've been meaning to blog about this for a while, including opening a feature request (at tracker.adobe.com) to request that they just put this in by default, like they so for the 127.0.0.1,0:0:0:0:0:0:0:1 values.

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2018 1
New Here ,
Aug 23, 2018

Copy link to clipboard

Copied

Charlie,

Thanks! That was easy and worked like a charm.  The administrator debugging IP page now lists these debugging IPs:

127.0.0.1 (added from admin via "Add Current" button)

0:0:0:0:0:0:0:1 (added from admin by adding "::1" )

::1 (manually added to neo-debug.xml file as you suggested)

Blog away!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2018 0
Adobe Community Professional ,
Aug 24, 2018

Copy link to clipboard

Copied

Thanks for the confirmation Adam, and the kind regards. And here's that blog post now done:

https://www.carehart.org/blog/client/index.cfm/2018/8/24/fixing_CF_debugging_output_for_ipv6_localho...

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2018 0
Adobe Community Professional ,
Aug 24, 2018

Copy link to clipboard

Copied

Oh, and I should have mentioned (as I do in the blog post) that I have now also reported this as a bug, so interested folks can go add their votes to get Adobe to resolve this in the Admin for us:

https://tracker.adobe.com/#/view/CF-4203295

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2018 0