Highlighted

Default Document not being honored after upgrade to CF11

Community Beginner ,
Jun 04, 2016

Copy link to clipboard

Copied

Windows 2008 R2

IIS 7.5

ColdFusion 11

We just upgraded our production environment from CF10 to CF11. We ran onto some snags with the dev environment on the upgrade, but not this particular issue.

The issue seems to be that the default/welcome document is not being honored.

Example:

If I go to http://server/dir/default.cfm everything is cool, but if I go to http://server/dir/ I get a 404 error.

HTTP Error 404.2 - Not Found

The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.

Detailed Error Information

ModuleIsapiModule
NotificationExecuteRequestHandler
HandlercfmHandler
Error Code0x800704ec

Requested URLhttp://server:80/default.cfm
Physical PathX:\dir\root\default.cfm
Logon MethodAnonymous
Logon UserAnonymous

Now I have checked/deleted/added the Handler Mappings, ISAPI Filters, and ISAPI and CGI Restrictions until I am half-mad. I have deleted the connector with wsconfig loads of times, and the only thing I see that stands out is in the isapi_redirect.log:

[debug] handle_notify_event::jk_isapi_plugin.c (2505): [/] is not a servlet url

I have checked permissions, checked everything I can find, and this time the forum below is not the answer. The IIS server serves up all the cfm files, etc. fine, it is just using the dir only that we have a problem (again).

Oh the irony, the closest issue I see in the forums, is from my own when we upgraded to 10 > Default Document not being honored after upgrade to CF10

Views

184

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Default Document not being honored after upgrade to CF11

Community Beginner ,
Jun 04, 2016

Copy link to clipboard

Copied

Windows 2008 R2

IIS 7.5

ColdFusion 11

We just upgraded our production environment from CF10 to CF11. We ran onto some snags with the dev environment on the upgrade, but not this particular issue.

The issue seems to be that the default/welcome document is not being honored.

Example:

If I go to http://server/dir/default.cfm everything is cool, but if I go to http://server/dir/ I get a 404 error.

HTTP Error 404.2 - Not Found

The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.

Detailed Error Information

ModuleIsapiModule
NotificationExecuteRequestHandler
HandlercfmHandler
Error Code0x800704ec

Requested URLhttp://server:80/default.cfm
Physical PathX:\dir\root\default.cfm
Logon MethodAnonymous
Logon UserAnonymous

Now I have checked/deleted/added the Handler Mappings, ISAPI Filters, and ISAPI and CGI Restrictions until I am half-mad. I have deleted the connector with wsconfig loads of times, and the only thing I see that stands out is in the isapi_redirect.log:

[debug] handle_notify_event::jk_isapi_plugin.c (2505): [/] is not a servlet url

I have checked permissions, checked everything I can find, and this time the forum below is not the answer. The IIS server serves up all the cfm files, etc. fine, it is just using the dir only that we have a problem (again).

Oh the irony, the closest issue I see in the forums, is from my own when we upgraded to 10 > Default Document not being honored after upgrade to CF10

Views

185

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 04, 2016 0

Have something to add?

Join the conversation