Highlighted

Default ScriptSrc folder plus strictnumbervalidation

New Here ,
May 25, 2017

Copy link to clipboard

Copied

I have a ColdFusion 11 server set up and I've set one up and it works fine with no problems. However on another server that is built I can't get the following working at the same time together.

I have my DefaultScriptSrc pointing to a newly named virtual directory in IIS as per the lockdown guide. For instance I have a virtual directory called "cfscripts".  This virtual directory points to the CFIDE\scripts directory in IIS.  Therefore in CFadmin I have the parameter set to "\cfscripts\"

1. Cfform works just fine.  You can clearly see that it's looking for cfform.js in src="/cfscripts/cfform.js"

2. However we set the parameter "strictnumbervalidation=false" at the top of our code in the apps as we want it to behave like in prior ColdFusion releases.  This does not work.

If I change the virtual directory cfscripts to point to CFIDE instead of CFIDE\scripts then the strictnumbervalidation works but the cfform doesn't. I'm not sure why on this server it works this way.

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Default ScriptSrc folder plus strictnumbervalidation

New Here ,
May 25, 2017

Copy link to clipboard

Copied

I have a ColdFusion 11 server set up and I've set one up and it works fine with no problems. However on another server that is built I can't get the following working at the same time together.

I have my DefaultScriptSrc pointing to a newly named virtual directory in IIS as per the lockdown guide. For instance I have a virtual directory called "cfscripts".  This virtual directory points to the CFIDE\scripts directory in IIS.  Therefore in CFadmin I have the parameter set to "\cfscripts\"

1. Cfform works just fine.  You can clearly see that it's looking for cfform.js in src="/cfscripts/cfform.js"

2. However we set the parameter "strictnumbervalidation=false" at the top of our code in the apps as we want it to behave like in prior ColdFusion releases.  This does not work.

If I change the virtual directory cfscripts to point to CFIDE instead of CFIDE\scripts then the strictnumbervalidation works but the cfform doesn't. I'm not sure why on this server it works this way.

Views

229

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 25, 2017 0
BKBK LATEST
Adobe Community Professional ,
May 27, 2017

Copy link to clipboard

Copied

If, as you say, you followed the lockdown guide, then verify that your settings are as follows:

Virtual directory alias in web server for cfscripts folder: /cfscripts

Physical path: {cf.instance.webroot}/CFIDE/scripts

Value for "Default ScriptSrc Directory" in ColdFusion Administrator: /cfscripts/

Should you make any changes, you should restart ColdFusion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2017 0