Highlighted

Error 500 after installing CF11 on Windows 8.1 Coldfusion 32bit

New Here ,
Dec 15, 2014

Copy link to clipboard

Copied

We are having trouble getting coldfusion11 32bit to work on a windows 8.1 64bit machine.

I followed all the steps in the thread Error 500 after installing CF11 on Windows 8.1

but we are still have a problem when we run the admin page  "http://localhost/CFIDE/administrator/index.cfm"

it returns "HTTP Error 500.0 - Internal Server Error" and we have been unable to find a solution.

All the handlers appear to be installed correctly and we have set the application pool default "true" so to allow  32bit applications.. (PS tried it both True and False no difference)

and the security settings are all set to "Full Control"

Any help with this matter is greatly appreciated

handler.jpg

32 bit setting.jpg

security settings.jpg

Cool. That confirms, ColdFusion is working.

Test B:

  1. Can you create a test site in IIS and place a test html and a test cfm page.
  2. Now, browse to the html page and it should render in the browser.
  3. Now create a connector to the site and access the test html and test cfm page
  4. If you get error 500, then ensure the bitness of both CF and IIS.
  5. Else, if you get error 500.19 or any other, please ensure that you have permissions on \ColdFusion11\config\wsconfig\

Let me know the results.

Regards,

Anit Kumar

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error 500 after installing CF11 on Windows 8.1 Coldfusion 32bit

New Here ,
Dec 15, 2014

Copy link to clipboard

Copied

We are having trouble getting coldfusion11 32bit to work on a windows 8.1 64bit machine.

I followed all the steps in the thread Error 500 after installing CF11 on Windows 8.1

but we are still have a problem when we run the admin page  "http://localhost/CFIDE/administrator/index.cfm"

it returns "HTTP Error 500.0 - Internal Server Error" and we have been unable to find a solution.

All the handlers appear to be installed correctly and we have set the application pool default "true" so to allow  32bit applications.. (PS tried it both True and False no difference)

and the security settings are all set to "Full Control"

Any help with this matter is greatly appreciated

handler.jpg

32 bit setting.jpg

security settings.jpg

Cool. That confirms, ColdFusion is working.

Test B:

  1. Can you create a test site in IIS and place a test html and a test cfm page.
  2. Now, browse to the html page and it should render in the browser.
  3. Now create a connector to the site and access the test html and test cfm page
  4. If you get error 500, then ensure the bitness of both CF and IIS.
  5. Else, if you get error 500.19 or any other, please ensure that you have permissions on \ColdFusion11\config\wsconfig\

Let me know the results.

Regards,

Anit Kumar

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 15, 2014 0
Explorer ,
Dec 15, 2014

Copy link to clipboard

Copied

While installing connector from wsconfig there is an option to install 32 bit connector. There will be a checkbox mentioning it, make sure that is checked.

If you have already installed a connector then uninstall it and install it again.

Rest all settings remain same like 'enable 32 applications' remains true.

Also make sure you have Visual C++ 2012 update 4 redistributable package installed in your machine.

Please try and let me know.

Thanks,

Milan.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

I reset IIS application pools defaults to "Enable 32-Bit Applications" to   "False"

installed the update for  "Visual Studio 2012 Update 4" which includes the C++ update referred to by mchandna above

Ran the batch file  "Remove_ALL_connectors.bat"  verified they were missing in IIS.

Then re-ran the application "wsconfig.exe" however there does not appear to be any check box for 32-bit applications ( see images below)

I saw that "wsconfig.exe" accepts command line arguments... Is there a argument for 32-bit?

stopped and restarted coldfusion services and re-tested

still get the error "500.0 Error"

any other ideas?

wsconfig.jpg

wsconfig-Advance_setting.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Advocate ,
Dec 17, 2014

Copy link to clipboard

Copied

Have you tried using failed request tracing to see if it will give you the exact point of it failing?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

In your case, "Enable 32-Bit Applications" should be set to "true". Your screenshot shows, that your CF is running in 32-bit.


Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

I returned the  "Enable 32-Bit Applications"  back to "True"

and installed "Failed request tracking" in windows and restarted IIS and Coldfusion

also tried "Enable verbose logging for connector"   not sure where this log would be?


re-ran the admin page  "http://localhost/CFIDE/administrator/index.cfm"    Same 500.0 error

yet the directory "inetpub\logs\FailedReqLogFiles\"  is empty??


any other ideas?


Thanks so much for your help!!


failed_request_tracing.jpg

no_logfile.jpg

tried_verpose-logging-for-connector.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Please refer to Create a Tracing Rule for Failed Requests (IIS 7) and set the range from 200-600 in FREB settings.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

Here is the trace result file.xml  I posted to our server so you could see it...

I don't don't know what I am looking at ???

Any Ideas are greatly appreciated

http://www.oehq.com/temp/failed_request.xml

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

I sent a link to our server with the failed_request.xml file

The forum says Moderated??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Approved.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Can you share the freb.xsl and the freb xml, probably zip it and share it.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

I did not see a file called freb.xml I did have a xml in the log folder so i included it with the freb.xsl

both in freb.zip

try this  "ftp://www.oehq.com/"

user: adobe

pass: adobe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

I got the file. Kindly delete the user account "adobe", you created.

I checked the file. it says,

Urlhttp://localhost:80/CFIDE/administrator/index.htm

Can you change the url to http://localhost/CFIDE/administrator/index.cfm and try again?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 17, 2014

Copy link to clipboard

Copied

Thanks,

I tested the wrong page last time before I sent you the file

re-ran using the cfm page "http://localhost/CFIDE/administrator/index.cfm"  but still getting the 500.0 error  "UGH"

I re-zipped the trace folder and put it up on the ftp server for your review f the new files

Thanks so much for your help... you are the best!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Can you add "IUSR" to wsconfig and try again? Its unable to read the isapi_redirect.dll.

If that doesn't work try giving access to "everyone"?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
New Here ,
Dec 18, 2014

Copy link to clipboard

Copied

I changed the rights to the wsconfig folder to "everyone" and re-tested  still no luck  UGH!

IIS is working... Just can't seem to  to get CF to work

I uploaded the latest failed_request files to our server for your review.

I can not express our appreciation enough for all your help

rights_wsconfig.jpg

IIS_Works.jpg

CF_Not_Working.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Advocate ,
Dec 18, 2014

Copy link to clipboard

Copied

Do you have an IUSR account on this machine? (different to the IIS_IUSRS). Has this been given full permission?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
New Here ,
Dec 18, 2014

Copy link to clipboard

Copied

I added the IUSR account and gave it "Full Control"

still getting the 500.0 error

IUSR_Rights.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

I am going to give you two suggestions here. Please let me know the end results:-

Test A:

  • Enable the built-in server of ColdFusion. Please ignore, if already enabled. You can try the following steps to enable the same:-
  • Open the cfroot\cfusion\runtime\conf\server.xml file.
  • Search for internal webserver start. Uncomment the following connector XML.

        <Connector executor="tomcatThreadPool" port="8500" protocol="org.apache.coyote.http11.Http11NioProtocol" connectionTimeout="20000" redirectPort="8445"/>

Note: the port 8500 may vary, on your server.

Test B:

  1. Can you create a test site and place a test html and a test cfm page.
  2. Now, browse to the html page and it should render in the browser.
  3. Now create a connector to the site and access the test html and test cfm page
  4. If you get error 500, then ensure the bitness of both CF and IIS.
  5. Else, if you get error 500.19 or any other, please ensure that you have permissions on \ColdFusion11\config\wsconfig\

Test C:

  1. Launch Command prompt as Administrator.
  2. Browse to the location \ColdFusion11\jre\bin\ and type this command “java -version”
  3. Capture the Java HotSpot(TM) bitness 32/64.

Let me know the results.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
New Here ,
Dec 18, 2014

Copy link to clipboard

Copied

Both the CFM and HTML pages rendered using the CF_server

See attached screen shots

Hope this helps

Thanks

successfull_CF_page_under-CFserver.jpg

successfull_HTML_page_under-CFserver.jpg

TestC_-Result.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

Cool. That confirms, ColdFusion is working.

Test B:

  1. Can you create a test site in IIS and place a test html and a test cfm page.
  2. Now, browse to the html page and it should render in the browser.
  3. Now create a connector to the site and access the test html and test cfm page
  4. If you get error 500, then ensure the bitness of both CF and IIS.
  5. Else, if you get error 500.19 or any other, please ensure that you have permissions on \ColdFusion11\config\wsconfig\

Let me know the results.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
New Here ,
Dec 19, 2014

Copy link to clipboard

Copied

I was able to build a test site in IIS "localstuff" and the test htm page works fine on this site, however the cfm page fails with 500.0

(see screen shots below)

If I put both the pages under the "localhost/CFIDE/admininstrator/" location then they both work?

when I check the handlers under the test site  "localstuff"  they do show the CF handlers

I double checked the rights and they are set to "Full Control" everyone.

any other ideas?

Thanks for the help!!

test site shows the cfm connectors.jpg

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

html page runs on localhost.jpg

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

coldfusion page fails on localhost.jpg

permissions set to everyone_jpg.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2014 0
haxtbh LATEST
Advocate ,
Dec 21, 2014

Copy link to clipboard

Copied

What is the detailed error information on the 500 page?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2014 0
New Here ,
Dec 16, 2014

Copy link to clipboard

Copied

Try setting the "Enable 32 bit applications" to FALSE in Application Pool and select checkbox "Enable 32bit applications" using wsconfig and configure the site. It should work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2014 0
Enthusiast ,
Dec 18, 2014

Copy link to clipboard

Copied

type localhost in the browser's url to test whether iis home page is coming or not.

If not, then add the same in the hosts file. Then try once again with localhost as well as accessing CF 11 administrator.

If yes, then create a new site in IIS and assign "Everyone" to the webroot of that site. Place a test.htm and .cfm to test it's working or not.

HTH

Thanks

VJ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0