Highlighted

Error configuring RDS with Report Builder

New Here ,
Feb 05, 2015

Copy link to clipboard

Copied

I setup coldfusion 11 in a development environment using Apache Server about three months ago. I just installed Report Builder and cannot get it to connect through RDS. I tried first through Port 80 and 8500 and received a message that said "WebServer was unreachable." I checked my server settings and noticed under WebSocket it was configured to use port 8577. I tried configuring RDS using this port and received a 403 Forbidden message. RDS is enabled, I have tried changing passwords and disabling the password. I have searched this forum and many others and cannot find an answer on how to remedy this. Can someone please help or point me to a previous post?

I am using localhost for hostname and Port 8577. Context Root is blank, User Name is blank, and I have tried using both RDS and Admin password.

Thanks,

Shugoro

Views

953

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error configuring RDS with Report Builder

New Here ,
Feb 05, 2015

Copy link to clipboard

Copied

I setup coldfusion 11 in a development environment using Apache Server about three months ago. I just installed Report Builder and cannot get it to connect through RDS. I tried first through Port 80 and 8500 and received a message that said "WebServer was unreachable." I checked my server settings and noticed under WebSocket it was configured to use port 8577. I tried configuring RDS using this port and received a 403 Forbidden message. RDS is enabled, I have tried changing passwords and disabling the password. I have searched this forum and many others and cannot find an answer on how to remedy this. Can someone please help or point me to a previous post?

I am using localhost for hostname and Port 8577. Context Root is blank, User Name is blank, and I have tried using both RDS and Admin password.

Thanks,

Shugoro

Views

954

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 05, 2015 0
Advocate ,
Feb 09, 2015

Copy link to clipboard

Copied

Is your workstation stand-alone or is it part of a domain?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

It is stand-alone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

shugoro wrote:

It is stand-alone.

Okay, then localhost should work.

The port number required is the port on which the HTTP service is listening.

When you go to the ColdFusion Administration Web site, what does the full URL look like?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

shugoro wrote:

http://127.0.0.1/CFIDE/administrator/index.cfm

Good, you're using the default port 80.

Try the following configuration:

Host name: localhost

Port: 80

Do not use SSL

Context Root: (leave blank)

User Name: admin

Password: (leave blank)

Do not prompt for password.

Click the "Test Connection" button. What happens?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

I tried the configuration you suggested, resulted in the following error:

The following error occurred while trying to connect to the RDS Server:

HTTP/1.1 404 Not Found

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

Are you using IPv6 on this machine and what OS is it using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

OS is Windows 7 Enterprise, and yes, it looks like it has been set up using IPv6

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

Ah. Edit your hosts file and be sure localhost resolves to an IPv4 address.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

OK, I updated host file to resolve to IPv4. When I ping localhost it now resolves to 127.0.0.1. I am still receiving the same error (HTTP/1.1 404 Not Found) when testing connection

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

Very strange.

Open a command prompt and type tracert 127.0.0.1

Does the first line of the result show "Tracing route to localhost" or some other machine name?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

It traces to the local machine name "Tracing route to Mat-PC [127.0.0.1]"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

Ah! Change localhost to Mat-PC in your RDS configuration and test the connection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

I tried using machine name (Mat-PC), 127.0.0.1, and localhost - all result in the same error (HTTP/1.1 414 Not Found). I tried putting a random name in, and I receive message that "webserver was unreachable." It appears it is resolving the name OK,

If I change the port to a port other than 80, I also receive the message  "webserver was unreachable".

The user name does not seem to make any difference. I can use a local account name, admin, or any random name. The error messages only seem to be generating from the content in the Host Name and Port fields.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

Wow.

At this point it would be worth doing a clean installation of your development environment in a virtual machine or another physical machine that does not have CF or CF Report Builder on it.

If you can get that second installation working you can then compare the configurations and see what's different.

Also, if you have Dreamweaver or CF Builder, you can try setting up RDS in those and see if they manage to succeed in connecting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
New Here ,
Feb 10, 2015

Copy link to clipboard

Copied

OK... Is there any possibility it could be related to the Context Root? I am running ColdFusion on Apache.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0
Advocate ,
Feb 10, 2015

Copy link to clipboard

Copied

I have no experience with Apache, but if you installed the CF Server as a J2EE application and you know what its context root is, then yes, add that to the RDS configuration.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2015 0