Highlighted

Error establishing socket to host: Reason: Connection refused: connect

Participant ,
Aug 15, 2009

Copy link to clipboard

Copied

I am in the process of moving from an old x32 server to a new x64 bit server.  With the help of Adobe support, I have finally gotten CF8.0.1 up and running on the new server: http://forums.adobe.com/thread/470337?tstart=0,

I am now trying to connect CF8.0.1 Standard on the new x64 machine to SQLServer 2005 x64 bit. All of the databases I'm trying to setup on the new server are currently running on a x32 system with CF8.0.1 and SQLServer 2005 x32.

CFVerInfo.JPG

Using the SQLServer drive type I get the following error:

"Connection verification failed for data source: PHREDsevenSQL
java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket to host and port: DELLx64Server:1433. Reason: Connection refused: connect
The root cause was that: java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket to host and port: DELLx64Server:1433. Reason: Connection refused: connect."

Using the ODBC Socket type I do not get a ODBC DSN name in the select box so I can't actually try this type of connection. I've tried both x32 and x64 bit ODBC System setups.

P7SQL_def.JPG

I have verified the following:

SQLServer configuration: the port is set to 1433.

Account user name and password are correct.

I have looked for a x64 bit SQLServer driver for CF8 on Adobe, but couldnt find one. Perhaps one is already installed.

If anyone has a suggestion or solution, I would appreicate your help.   Thanks in advance for your help.

:-}}}

Len

Things to check

1. Is SQL authentication enabled on the new SQL server?  This is disabled in the default install.

2. Does the SQL server accept remote TCP/IP connections?

    a. This article may help:
    "How to configure SQL Server 2005 to allow remote connections"
    http://support.microsoft.com/kb/914277

    b. Verify that connections are not being blocked by a firewall.

TOPICS
Database access, Server administration

Views

18.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error establishing socket to host: Reason: Connection refused: connect

Participant ,
Aug 15, 2009

Copy link to clipboard

Copied

I am in the process of moving from an old x32 server to a new x64 bit server.  With the help of Adobe support, I have finally gotten CF8.0.1 up and running on the new server: http://forums.adobe.com/thread/470337?tstart=0,

I am now trying to connect CF8.0.1 Standard on the new x64 machine to SQLServer 2005 x64 bit. All of the databases I'm trying to setup on the new server are currently running on a x32 system with CF8.0.1 and SQLServer 2005 x32.

CFVerInfo.JPG

Using the SQLServer drive type I get the following error:

"Connection verification failed for data source: PHREDsevenSQL
java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket to host and port: DELLx64Server:1433. Reason: Connection refused: connect
The root cause was that: java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket to host and port: DELLx64Server:1433. Reason: Connection refused: connect."

Using the ODBC Socket type I do not get a ODBC DSN name in the select box so I can't actually try this type of connection. I've tried both x32 and x64 bit ODBC System setups.

P7SQL_def.JPG

I have verified the following:

SQLServer configuration: the port is set to 1433.

Account user name and password are correct.

I have looked for a x64 bit SQLServer driver for CF8 on Adobe, but couldnt find one. Perhaps one is already installed.

If anyone has a suggestion or solution, I would appreicate your help.   Thanks in advance for your help.

:-}}}

Len

Things to check

1. Is SQL authentication enabled on the new SQL server?  This is disabled in the default install.

2. Does the SQL server accept remote TCP/IP connections?

    a. This article may help:
    "How to configure SQL Server 2005 to allow remote connections"
    http://support.microsoft.com/kb/914277

    b. Verify that connections are not being blocked by a firewall.

TOPICS
Database access, Server administration

Views

18.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 15, 2009 0
Advisor ,
Aug 17, 2009

Copy link to clipboard

Copied

Things to check

1. Is SQL authentication enabled on the new SQL server?  This is disabled in the default install.

2. Does the SQL server accept remote TCP/IP connections?

    a. This article may help:
    "How to configure SQL Server 2005 to allow remote connections"
    http://support.microsoft.com/kb/914277

    b. Verify that connections are not being blocked by a firewall.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2009 0
Participant ,
Aug 17, 2009

Copy link to clipboard

Copied

Bob,

     The problem was that SQLServer was not setup for remote access.  I set it to for TCP/IP use the procedure in 914277 as you suggested and it is now working.

     I can now create a Data Source from CF8, so after a couple of false starts I'm finally up and running on my new server.

     Thanks to everyone for your help and suggestions.

:-}}}

Len

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2009 0
New Here ,
Mar 20, 2017

Copy link to clipboard

Copied

hiiii

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Explorer ,
Jul 11, 2018

Copy link to clipboard

Copied

For me the issue was TCP/IP protocols were disabled (the second option in the accepted answer). However, why I chose to write my own version of the truth is because I had a tough time getting to the crux of the matter. I am on Windows 10. In short, just follow this:

a) Go To start Menu

b) Type and select 'SQl Server <version> Configuration manager'

c) Select 'Protocols for MSSQLSERVER' under SQL Server Network Configuration. Refer below image:

d) Right Click on TCP/IP and select Enable.

e) Restart SQL server services from the same window .

f) Now you are good to go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 11, 2018 2
Engaged ,
Aug 17, 2009

Copy link to clipboard

Copied

You will need to examine the logs in at least four places:

  1. ColdFusion server application.
  2. ColdFusion host operating-system.
  3. (Possibly:  intervening security appliances and/or routers.)
  4. SQL Server host operating-system.
  5. SQL Server application.

If a connection was refused, it undoubtedly also was recorded.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2009 0