Highlighted

Error when displaying first page in Browser

New Here ,
Jul 18, 2020

Copy link to clipboard

Copied

I get the following error:

Error Occurred While Processing Request
Could not find the included template JRCScripts.cfm.
Note: If you wish to use an absolute template path (e.g. TEMPLATE="/mypath/index.cfm") with CFINCLUDE then you must create a mapping for the path using the ColdFusion Administrator. Using relative paths (e.g. TEMPLATE="index.cfm" or TEMPLATE="../index.cfm") does not require the creation of any special mappings. It is therefore recommended that you use relative paths with CFINCLUDE whenever possible.

The error occurred in /vservers/jamestownclass/htdocs/indexclassic.cfm: line 12
10 : <META HTTP-EQUIV="Expires" CONTENT="-1">11 :
12 : <link href="\organized.css" rel="stylesheet" type="text/css">
13 : <!-- InstanceEndEditable -->
14 : </head>

code  of first page is 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<!-- InstanceBegin template="/Templates/JRCMain.dwt.cfm" codeOutsideHTMLIsLocked="false" -->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<!-- InstanceBeginEditable name="doctitle" -->
<title>JamestownClassic</title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">

<link href="\organized.css" rel="stylesheet" type="text/css">
<!-- InstanceEndEditable -->
</head>

<body bottommargin="0" topmargin="0" leftmargin="0" rightmargin="0" marginheight="0" marginwidth="0">
include "MYScripts.cfm";

 

I do not see what the error is. Please help!!  I've  tried eliminating all referneces to JRCScripts.cfm

That does not solve the problem.  MyScrips.cfm and JRCScripts.cfm are the same.

 

Gail thomas

Views

38

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error when displaying first page in Browser

New Here ,
Jul 18, 2020

Copy link to clipboard

Copied

I get the following error:

Error Occurred While Processing Request
Could not find the included template JRCScripts.cfm.
Note: If you wish to use an absolute template path (e.g. TEMPLATE="/mypath/index.cfm") with CFINCLUDE then you must create a mapping for the path using the ColdFusion Administrator. Using relative paths (e.g. TEMPLATE="index.cfm" or TEMPLATE="../index.cfm") does not require the creation of any special mappings. It is therefore recommended that you use relative paths with CFINCLUDE whenever possible.

The error occurred in /vservers/jamestownclass/htdocs/indexclassic.cfm: line 12
10 : <META HTTP-EQUIV="Expires" CONTENT="-1">11 :
12 : <link href="\organized.css" rel="stylesheet" type="text/css">
13 : <!-- InstanceEndEditable -->
14 : </head>

code  of first page is 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<!-- InstanceBegin template="/Templates/JRCMain.dwt.cfm" codeOutsideHTMLIsLocked="false" -->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<!-- InstanceBeginEditable name="doctitle" -->
<title>JamestownClassic</title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">

<link href="\organized.css" rel="stylesheet" type="text/css">
<!-- InstanceEndEditable -->
</head>

<body bottommargin="0" topmargin="0" leftmargin="0" rightmargin="0" marginheight="0" marginwidth="0">
include "MYScripts.cfm";

 

I do not see what the error is. Please help!!  I've  tried eliminating all referneces to JRCScripts.cfm

That does not solve the problem.  MyScrips.cfm and JRCScripts.cfm are the same.

 

Gail thomas

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 18, 2020 0
Adobe Community Professional ,
Jul 18, 2020

Copy link to clipboard

Copied

Look instead in any application.cfc or .cfm, in that htdocs folder or its parents, and also in any file that is included or any cfc method that's invoked from that.

 

Sadly, sometimes the cf error messages are not accurate. Let us know if that solves things. 

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 18, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

 

<link href="\organized.css" rel="stylesheet" type="text/css">

 

According to the error message, this is the line that is causing the problem.  URLs don't use backslash (\).  If this were a forward slash (/), it would be looking in the root folder for 'organized.css'.

 

 

include "MYScripts.cfm";

 

 

This looks like something that belongs inside a CFSCRIPT tag, but you don't include it in the code you posted.  And I don't see any reference to JRCScripts.cfm in the code you posted.  So I'm wondering if the code you posted in your thread is the same code that produced the error.  If it is, then something is very wrong.  If it isn't, then may we please see the code that actually triggered the error message?

 

V/r,

 

^ _ ^

 

UPDATE:  Just thought of something.  When you post code, please use the code format button (</>) to enter your code into.  It will open a dialog for you to enter or copy/paste code.  We may be missing some code due to the editor not liking HTML/CFML tags.  The code formatter is precisely for this reason.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
BKBK LATEST
Adobe Community Professional ,
Aug 09, 2020

Copy link to clipboard

Copied

Hi Gail,

ColdFusion might still be running a cached version of the page. So, delete the cached classes representing the pages.

 

To do so, go to the cfclasses directory (Mine is located at C:\ColdFusion2018\cfusion\wwwroot\WEB-INF\cfclasses). Select and delete all the class files.

 

That will force ColdFusion to recompile when you next launch a page. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2020 0