Highlighted

Failure to Create DNS to SQL Server?

Community Beginner ,
Jul 30, 2014

Copy link to clipboard

Copied

When I try to create a DNS to connect to a SQL Server Database (2014), I get a failure:

Connection verification failed for data source: soundings

java.sql.SQLNonTransientConnectionException: [macromedia][SQLServer JDBC Driver]The connection to the host HOMEBIZ, named instance SQLEXPRESS (local) has failed. Error: "Receive timed out". Verify the server and instance names, check that no firewall is blocking UDP traffic to port 1434, and for SQL Server 2005 or later verify that the SQL Server Browser Service is running on the host.

I've tried various ways to resolve this problem:

1)  I created rules to allow the requisite ports through the Firewall (Norton).

2)  I've run netstat - ano to get info on the ports:

TCP:  [: :]:61223  HOMEBIZ:0  Listening  PID: 4048

TCP:  0.0.0.0:61223 HOMEBIZ:0 Listening  PID: 4048

(This PID does correspond to the running SQL Server)

UDP:  [: :]:1434  *:*  PID: 6076

UDP:  0.0.0.0:1434  *:*  PID: 6076

(This PID does correspond to the running SQLBrowser)

I've gone into the ODBC DataSources (both 64 and 32 bit and have created DSNs to the database: when testing during the creation, I get a "successful" report --  So it is possible to reach the Database Server.

I've got this set up with Mixed Authenication -- so I'm not adding a username or password when creating the DNS (but I've tested it with and without: no difference)

I've looked for ways to set up some sort of connection string in Cold Fusion to try to connect outside the ColdFusion DNS but I've not been successful in finding the right instructions for doing that test.

Views

845

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Failure to Create DNS to SQL Server?

Community Beginner ,
Jul 30, 2014

Copy link to clipboard

Copied

When I try to create a DNS to connect to a SQL Server Database (2014), I get a failure:

Connection verification failed for data source: soundings

java.sql.SQLNonTransientConnectionException: [macromedia][SQLServer JDBC Driver]The connection to the host HOMEBIZ, named instance SQLEXPRESS (local) has failed. Error: "Receive timed out". Verify the server and instance names, check that no firewall is blocking UDP traffic to port 1434, and for SQL Server 2005 or later verify that the SQL Server Browser Service is running on the host.

I've tried various ways to resolve this problem:

1)  I created rules to allow the requisite ports through the Firewall (Norton).

2)  I've run netstat - ano to get info on the ports:

TCP:  [: :]:61223  HOMEBIZ:0  Listening  PID: 4048

TCP:  0.0.0.0:61223 HOMEBIZ:0 Listening  PID: 4048

(This PID does correspond to the running SQL Server)

UDP:  [: :]:1434  *:*  PID: 6076

UDP:  0.0.0.0:1434  *:*  PID: 6076

(This PID does correspond to the running SQLBrowser)

I've gone into the ODBC DataSources (both 64 and 32 bit and have created DSNs to the database: when testing during the creation, I get a "successful" report --  So it is possible to reach the Database Server.

I've got this set up with Mixed Authenication -- so I'm not adding a username or password when creating the DNS (but I've tested it with and without: no difference)

I've looked for ways to set up some sort of connection string in Cold Fusion to try to connect outside the ColdFusion DNS but I've not been successful in finding the right instructions for doing that test.

Views

846

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 30, 2014 0
Community Beginner ,
Jul 30, 2014

Copy link to clipboard

Copied

Is this a fresh install ? Please check this link, it may help.

ColdFusion10 – Issue In Create DSN For SQL Server | ColdFusion Experts

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2014 1
wtbell3 LATEST
Community Beginner ,
Jul 31, 2014

Copy link to clipboard

Copied

The article you pointed me to was very helpful  --  it did not lead to an exact solution but took me 99% of the way!  I had done all the steps except  changing the SQLBrowser to "Network."  It was on "Local."

It still did not quite work with the Port set at the normal 1433.  I did another  netstat -ao and traced the PID for the SqlServer shown in Services to a different port:  61223.  Interestingly, this showed up with a local address of 0.0.0.0:61223 and not 127.0.0.1:61223 but when I set the server to 127.0.0.1 and the port to 61223 and added the sa password, it worked.  (Some other instructions I read said that you should leave off the sa password if you were using mixed authentication.)

So, in total, I think the key instruction was setting up the SQLBrowser to Network and not just on as failure message said.

I am a happy camper!  I got my answer in less than 24 hours!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 31, 2014 0