Highlighted

Files in WebServer/Documents/ Creating Unexpected Error Message

Explorer ,
Apr 25, 2018

Copy link to clipboard

Copied

Installed the beta, and had it set up to use the Apache server that is included in OS X on my laptop.  And, I'm using the 8500 port.  I have all the files in /Library/WebServer/Documents folder. In Httpd.conf I have "DocumentRoot "/Library/WebServer/Documents"".  

When I try to run 127.0.0.1/twitterstuff/testing.cfm I get:

Error Occurred While Processing Request

File not found: /twitterstuff/testing.cfm

However, when I move this directory into /Applications/ColdFusion2018/cfusion/wwwroot/CFIDE, this file runs.  This isn't an ideal answer to the problem, though.  Is this a bug, or some configuration I need to make somewhere else?

Okay, problem solved! The answer was to move the old mod_jk.conf file out of the directory, comment out the original include line in the http.conf, restart the Apache server and install CF2018.  Going to 127.0.0.1/twitterstuff/testing.cfm works properly now.  Thanks for your help.

Views

300

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Files in WebServer/Documents/ Creating Unexpected Error Message

Explorer ,
Apr 25, 2018

Copy link to clipboard

Copied

Installed the beta, and had it set up to use the Apache server that is included in OS X on my laptop.  And, I'm using the 8500 port.  I have all the files in /Library/WebServer/Documents folder. In Httpd.conf I have "DocumentRoot "/Library/WebServer/Documents"".  

When I try to run 127.0.0.1/twitterstuff/testing.cfm I get:

Error Occurred While Processing Request

File not found: /twitterstuff/testing.cfm

However, when I move this directory into /Applications/ColdFusion2018/cfusion/wwwroot/CFIDE, this file runs.  This isn't an ideal answer to the problem, though.  Is this a bug, or some configuration I need to make somewhere else?

Okay, problem solved! The answer was to move the old mod_jk.conf file out of the directory, comment out the original include line in the http.conf, restart the Apache server and install CF2018.  Going to 127.0.0.1/twitterstuff/testing.cfm works properly now.  Thanks for your help.

Views

301

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 25, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Files in the WebServer webroot are only served if the ColdFusion connector is configured. 

Without the connector being configured, ColdFusion only looks for files in the ColdFusion webroot. Once the connector has been configured, CFM files can be placed in the webserver webroot, and needs to be accessed via the webserver port (Not 8500). 

Please refer the following doc to configure connectors,
https://helpx.adobe.com/coldfusion/installing/configuring-your-system.html 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Okay . . . shouldn't this be made clear in the install process?  I thought that adding the Apache server at that stage would automatically make this config.  I know I didn't have this problem when I did previous CF versions installs. Can the Adobe staff confirm this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Was the connector configured during install? If yes, your connector configuration is already in place, unless an exception was thrown the first time you started ColdFusion.

Can you try accessing /twitterstuff/testing.cfm on your Apache port (Not 8500)?

p.s., I am Adobe staff 🙂 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

This is what I get: 

Service Unavailable

 

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

 

I'm going to try uninstalling and reinstalling.  First, this is what I see when I run the uninstall app:

Screen Shot 2018-04-26 09 11 30 AM

How do I unconfigure the connector?  For some reason, Apple has made it more difficult for users to mess around with Unix in OS X High Sierra and the installer seems to be designated the role of my user account. 

Thanks for clarification on your staff status!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

The connector requires root permissions, while the installer does not.

So here's how it works, during installation, the installer captures the connector configurations and connector is actually configured on first-time server startup attempt - the first startup requires root permissions. Once the connector is configured you will be prompted to restart ColdFusion server as a non-root user.

Now, since you probably have the connector configured, and need to uninstall the server, run the following command as root, and then uninstall your server.

sudo /Applications/ColdFusion2018/cfusion/runtime/bin/wsconfig -u

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Hmmm, when I ran the command, I got:  There are no configured web servers

Okay . . . my plan is to reinstall CF2018.  How do I make sure the connector gets configured properly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Okay, I went through the install process again.  Here's the options I'd selected. 

Screen Shot 2018-04-26 10 01 12 AM

Then. I navigated to the directory and ran sudo ./coldfusion start.  This is what I get:

Screen Shot 2018-04-26 10 05 35 AM

So there appears to be an error in the "/private/etc/apache2 connector wizard".  What could be the issue with the wizard, and how to fix it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Looking in the wsconfig log, here's what it says:

# Created by ColdFusion on 04/26 10:05:17

04/26 10:05:17 info Tomcat Connector

04/26 10:05:17 debug command line: -ws Apache -dir /private/etc/apache2 -bin /usr/sbin/httpd -script /usr/sbin/apachectl -connectionPoolTimeout 60 -reuseConnectionCount 250 -v 

04/26 10:05:17 debug Using Apache binary /usr/sbin/httpd

04/26 10:05:17 info Server version: Apache/2.4.29 (Unix)

04/26 10:05:18 debug Error while getting Apache Websites. Make sure you have administrator privilages

04/26 10:05:18 error This web server is already configured by some other version of ColdFusion.

com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstallerException: This web server is already configured by some other version of ColdFusion.

at com.adobe.coldfusion.connector.connectorinstaller.ApacheWebSites.parseConfFiles(ApacheWebSites.java:201)

at com.adobe.coldfusion.connector.connectorinstaller.ApacheWebSites.populateWebSites(ApacheWebSites.java:130)

at com.adobe.coldfusion.connector.connectorinstaller.ApacheInstaller.installConnector(ApacheInstaller.java:264)

at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.installConnector(ConnectorInstaller.java:456)

at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstaller.java:383)

 

at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstaller.java:921)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

The issue is that the webserver is already configured with an older version of ColdFusion that's installed.

With Apache, we can only have one version of ColdFusion configured. You could install another instance of Apache that's running on a separate port. But for now, can you unconfigure the connector from the older CF?

You will be able to do that by running the exact command I provided earlier, but on the older CF instance.

sudo /Applications/<OLDER CF INSTANCE>/cfusion/runtime/bin/wsconfig -u

I could help you get the ColdFusion 2018 setup up and runnng. Can you mail me at inoel@adobe.com.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

That's odd, because I just do not an older version of CF that is installed. CF2018 is the only one that I've deliberately installed on the laptop, which has never had CF installed until today. Although remnants may exist somewhere in the unix side since I had migrated files over here from my previous laptop, which did have CF installed.  Definitely I'll email you.

Edited to add:  Seems the problem was in /private/etc/apache2/mod_jk.conf - everything was referencing to the old directory as per "LoadModule    jk_module  "/Applications/ColdFusion2016/config/wsconfig/1/mod_jk.so""

Apparently this file didn't get written over or get saved as .conf_original; may I suggest that the installer check for this possibility? 


So, I'm going to try removing this file from the directory and running the install process again.  


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Explorer ,
Apr 26, 2018

Copy link to clipboard

Copied

Okay, problem solved! The answer was to move the old mod_jk.conf file out of the directory, comment out the original include line in the http.conf, restart the Apache server and install CF2018.  Going to 127.0.0.1/twitterstuff/testing.cfm works properly now.  Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
BKBK LATEST
Adobe Community Professional ,
Apr 28, 2018

Copy link to clipboard

Copied

lolajl

Please mark the answer as correct. It will certainly help someone else in future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2018 0