FTPS TLS session resumption

Community Beginner ,
Dec 19, 2015 Dec 19, 2015

Copy link to clipboard


I am trying to connect to an FTP server using port 990 (FTP using SSL).  From what I can tell, cfftp does not support FTPS - it only supports SFTP.  We have been doing using ftp4j and this has worked for us in the past.  See ColdFusion and FTP over implicit TLS/SSL :: Aliaspooryorik Musings.

However, the client has installed a new ftp server, and we can no longer drop more than a zero byte file.  In a manual test using FireFTP, we get the same error of "TLS session of data connection has not resumed or the session does not match the control connection".  A test using Filezilla client works however.  From what I can tell, this is because of needing to enforce TLS session resumption and the Filezilla client does this..

Has anyone dealt with and solved this in Coldfusion?







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation