Highlighted

getApplicationMetaData() broken in CF 2018 public beta

Community Beginner ,
Apr 18, 2018

Copy link to clipboard

Copied

Today I have installed the ColdFusion 2018 public beta and replaced the previous beta release with it. After installation the ColdBox 5 framework was broken, CF threw an error when trying to set a variable:

var appSettings = getApplicationMetadata();

For whatever reason dumping getApplicationMetadata() worked fine. However it only worked once - trying to dump it twice on the same page or assigning it to a variable resulted in an error.

Similar errors have been reported on the bug base (Tracker , Tracker)​ but are marked as fixed​ .

After verifying the bug I uninstalled the current public beta and replaced the installation with the previous version (from the closed beta) and it worked fine again. The current and previous beta release was reinstalled twice to verify that this bug only occurs with the latest beta (same code/same server configuration).

How to reproduce: Install a ColdBox 5 application on the current beta release server and it should break right away.

Regards,

Philipp

Views

272

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

getApplicationMetaData() broken in CF 2018 public beta

Community Beginner ,
Apr 18, 2018

Copy link to clipboard

Copied

Today I have installed the ColdFusion 2018 public beta and replaced the previous beta release with it. After installation the ColdBox 5 framework was broken, CF threw an error when trying to set a variable:

var appSettings = getApplicationMetadata();

For whatever reason dumping getApplicationMetadata() worked fine. However it only worked once - trying to dump it twice on the same page or assigning it to a variable resulted in an error.

Similar errors have been reported on the bug base (Tracker , Tracker)​ but are marked as fixed​ .

After verifying the bug I uninstalled the current public beta and replaced the installation with the previous version (from the closed beta) and it worked fine again. The current and previous beta release was reinstalled twice to verify that this bug only occurs with the latest beta (same code/same server configuration).

How to reproduce: Install a ColdBox 5 application on the current beta release server and it should break right away.

Regards,

Philipp

Views

273

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 18, 2018 0
Engaged ,
Apr 19, 2018

Copy link to clipboard

Copied

Thanks for bringing this up , we are verifying this 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2018 0
Engaged ,
Apr 20, 2018

Copy link to clipboard

Copied

We shall have an update for Public beta build soon which has the fix for CB 5

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2018 0
Community Beginner ,
Apr 20, 2018

Copy link to clipboard

Copied

Thanks for the quick response Suresh, looking forward to the new build.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2018 0
New Here ,
Apr 24, 2018

Copy link to clipboard

Copied

Hi Philipp,

We have made some fixes in getApplicationMetadata().

Can you apply the latest available update (Update 1 Public Beta) to ColdFusion 2018 (Public Beta) and let us know if the issue with ColdBox 5 framework is resolved now? 

Thanks,

Nitin 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2018 0
Community Beginner ,
Apr 25, 2018

Copy link to clipboard

Copied

Hi Nitin, 

thank you very much for the quick hotfix release! I can confirm that this has resolved any issues I had with CF 2018 Public Beta and ColdBox. 

Keep up the good work and thanks again, 

Philipp

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 0
Nitin_K LATEST
New Here ,
Apr 25, 2018

Copy link to clipboard

Copied

Thank you for the confirmation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 0