Highlighted

Help with how cfhttpparam work.

Engaged ,
Jan 27, 2016

Copy link to clipboard

Copied

This is what it says on the API Basics | KnowledgeOwl site. But it seemed that for it to work, the full URL look something like this.

https://app.knowledgeowl.com/api/head/category/5697c6a632131cd740bd3123.json?_authbykey=56a7d8c51233...

So, this is my attempt in using cfhttpparam.

<cfhttp url="https://app.knowledgeowl.com/api/head/category/.json?" method="GET" >

  <cfhttpparam name="categoryID" value="c6a632131cd740bd3123">

  <cfhttpparam name="_authbykey" value="56a7d8c512331c4058361687">

  <cfhttpparam name="project_id" value="55c4ffd131231c527e294fe6">

</cfhttp>

Okay, so I got Error in custom script module error. Any suggestion is much appreciated.

The url in the CFHTTP tag shouldn't end in a "?".   Also, you need the type="url" on the pram tags.

Views

188

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Help with how cfhttpparam work.

Engaged ,
Jan 27, 2016

Copy link to clipboard

Copied

This is what it says on the API Basics | KnowledgeOwl site. But it seemed that for it to work, the full URL look something like this.

https://app.knowledgeowl.com/api/head/category/5697c6a632131cd740bd3123.json?_authbykey=56a7d8c51233...

So, this is my attempt in using cfhttpparam.

<cfhttp url="https://app.knowledgeowl.com/api/head/category/.json?" method="GET" >

  <cfhttpparam name="categoryID" value="c6a632131cd740bd3123">

  <cfhttpparam name="_authbykey" value="56a7d8c512331c4058361687">

  <cfhttpparam name="project_id" value="55c4ffd131231c527e294fe6">

</cfhttp>

Okay, so I got Error in custom script module error. Any suggestion is much appreciated.

The url in the CFHTTP tag shouldn't end in a "?".   Also, you need the type="url" on the pram tags.

Views

189

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 27, 2016 0
Advocate ,
Jan 27, 2016

Copy link to clipboard

Copied

You are missing the type="URL" parameter. I'm not sure if there is a default type or not but that is where I would start.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 1
Engaged ,
Jan 27, 2016

Copy link to clipboard

Copied

The url in the CFHTTP tag shouldn't end in a "?".   Also, you need the type="url" on the pram tags.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
2Charlie LATEST
Engaged ,
Jan 27, 2016

Copy link to clipboard

Copied

Thanks, guys! That works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0