Highlighted

How to configure ESAPI?

New Here ,
Jun 08, 2015

Copy link to clipboard

Copied

Hi,

I'm getting this error : Variable ESAPIENCODER is undefined.

my code is this:

<cfset esapi = CreateObject("java", "org.owasp.esapi.ESAPI") />

  <cfset esapiEncoder = esapi.encoder() />

not sure what I missed in the configuration.

I do appreciate any help.

Thanks in advance,

rdm

Views

276

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to configure ESAPI?

New Here ,
Jun 08, 2015

Copy link to clipboard

Copied

Hi,

I'm getting this error : Variable ESAPIENCODER is undefined.

my code is this:

<cfset esapi = CreateObject("java", "org.owasp.esapi.ESAPI") />

  <cfset esapiEncoder = esapi.encoder() />

not sure what I missed in the configuration.

I do appreciate any help.

Thanks in advance,

rdm

Views

277

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 08, 2015 0
Advocate ,
Jun 08, 2015

Copy link to clipboard

Copied

There is no other code referencing "esapiEncoder"? Usually this error occurs later on in the code when you try and reference something that doesn't exists. What you posted shouldn't give you that error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2015 1
New Here ,
Jun 08, 2015

Copy link to clipboard

Copied

Thanks haxtbh. you gave me an idea. Solved the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2015 0