Highlighted

How to increase the maximum number of request to Coldfusion10 page.

New Here ,
Sep 03, 2015

Copy link to clipboard

Copied

Hi,

We are using Enterprise version of Coldfusion10 with 3 instance.

A maximum of 100 users is able to access the application with a little bit of slowness after which either the subsequent request hangs or becomes very slow until the requests of the first 100 users is completed and then the page loads.

I would like to know how to increase the maximum number of simultaneous concurrent requests for a 64-bit coldfusion10 instance with a hardware specification of 8 virtual cores and 16GB RAM with 6GB RAM allocated for the JVM Heap size.

Thanks,

Karthikeyan K

Views

885

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to increase the maximum number of request to Coldfusion10 page.

New Here ,
Sep 03, 2015

Copy link to clipboard

Copied

Hi,

We are using Enterprise version of Coldfusion10 with 3 instance.

A maximum of 100 users is able to access the application with a little bit of slowness after which either the subsequent request hangs or becomes very slow until the requests of the first 100 users is completed and then the page loads.

I would like to know how to increase the maximum number of simultaneous concurrent requests for a 64-bit coldfusion10 instance with a hardware specification of 8 virtual cores and 16GB RAM with 6GB RAM allocated for the JVM Heap size.

Thanks,

Karthikeyan K

Views

886

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 03, 2015 0
Guide ,
Sep 03, 2015

Copy link to clipboard

Copied

Hi Karthikeyan,

That slowness could be tomcat tuning. This blog could be helpful.

http://blogs.coldfusion.com/post.cfm/coldfusion-11-iis-connector-tuning

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 03, 2015 0
Adobe Community Professional ,
Sep 08, 2015

Copy link to clipboard

Copied

Wow, Karthikeyan.K,

with your set-up you should easily handle thousands of requests, simultaneously and fast. I suspect your settings are throttling down the number of simultaneous requests.

Open the Coldfusion Administrator. Navigate to Server Settings => Request Tuning, and modify the settings accordingly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2015 0
New Here ,
Sep 08, 2015

Copy link to clipboard

Copied

Hi,

Please find my setting below and let me know what changes needs to be done to handle thousands of request.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2015 0
Guide ,
Sep 08, 2015

Copy link to clipboard

Copied

Hi,

Hopefully more than able BKBK can keep working that idea forward.

I am more interested to know what workers.properties (\ColdFusion10\config\wsconfig\N N=1,2,3 or more) and AJP section of server.xml (\ColdFusion11\instance\runtime\conf) says.

Also worth a mention some of the CF10 updaters incremented the tomcat connector but one would have to manually upgrade the ISAPI connector file with WSCONFIG tool since the update process does not do that for you.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2015 0
Adobe Community Professional ,
Sep 10, 2015

Copy link to clipboard

Copied

I would say, set the maximum number of simultaneous template requests to 1000. Having said that, I would add that I now suspect something else. That is because the setting is 150, yet you still have difficulties with 100 users.

It's all about a restriction on the number of threads. So, like Carl Type3, I now suspect that the issue is caused by a restriction on the number of worker threads. You may have to change the settings for maximum number of threads in the configuration file of your web server. Which web server do you use? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2015 0
New Here ,
Sep 21, 2015

Copy link to clipboard

Copied

Hi BKBK,

I use IIS 8.0.

Thanks,

Karthikeyan K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2015 0
Guide ,
Sep 22, 2015

Copy link to clipboard

Copied

Hi Karthikeyan,

I am interested to know what workers.properties (\ColdFusion10\config\wsconfig\N N=1,2,3 or more) and AJP section of server.xml (\ColdFusion10\instance\runtime\conf) says.

EG

workers.properties:

worker.list=cfusion

worker.cfusion.type=ajp13

worker.cfusion.host=localhost

worker.cfusion.port=8012

worker.cfusion.max_reuse_connections=250

server.xml AJP part:

<Connector port="8012" redirectPort="8447" protocol="AJP/1.3" tomcatAuthentication="false"/>

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2015 0