Highlighted

How to turn off auto complete

Community Beginner ,
Jun 13, 2019

Copy link to clipboard

Copied

Been using CFBuilder for a while and cannot figure out HOW to stop it from autocompleting.

Specifically ... <cfif>  it adds the </cfif>  I found a couple of setting that appear to control it but it still insists on auto completing!  ARGH!

And then it gets really stupid when it finds a <input> within the <cfif> and tries to add </inout

It also adds ] to [   ) to (   # to # so you get ##

I wish CF Studio was compatible with WIndows 7 and 10?

I must be missing the obvious!?

TOPICS
Builder

Views

620

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to turn off auto complete

Community Beginner ,
Jun 13, 2019

Copy link to clipboard

Copied

Been using CFBuilder for a while and cannot figure out HOW to stop it from autocompleting.

Specifically ... <cfif>  it adds the </cfif>  I found a couple of setting that appear to control it but it still insists on auto completing!  ARGH!

And then it gets really stupid when it finds a <input> within the <cfif> and tries to add </inout

It also adds ] to [   ) to (   # to # so you get ##

I wish CF Studio was compatible with WIndows 7 and 10?

I must be missing the obvious!?

TOPICS
Builder

Views

621

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 13, 2019 0
Adobe Community Professional ,
Jun 13, 2019

Copy link to clipboard

Copied

First, please tell us exactly which CFBuilder you are using (2018, 2016, 11, 3, 2), and also whether you have applied all available updates for that (via the Help>Check for Updates menu). If you are on a version that has updates you've not applied, that could fix the oddity you are experiencing.

As for how to disable auto-closing of tags, in modern versions it's in Preferences>ColdFusion>Profiles>Editor>Typing, as "auto-close tags", with an option of "never".

(As for how you would "find" that, well, the Preferences page in Builder (Eclipse) DOES have a filter feature. If you typed "typing", you would be taken right to this page. It should also be that if you typed "close", it should have found it also (which you may have tried), but it does not work. That seems a bug. All settings should be filter-able.)

Finally, as for CF Studio, that ship has sailed.  We should never expect Adobe to update or resurrect it. But if you are unhappy with CF Builder, there are many alternatives that many CFers are enjoying, such as Visual Studio Code, Sublime Text, Atom, Brackets, NotePad++, and others--all of which offer CFML support of one sort or another. I keep a list of such CFML-supporting editors here:

http://www.cf411.com/editcf

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2019 0
Community Beginner ,
Jun 13, 2019

Copy link to clipboard

Copied

Well, I checked for updates ... installed them and now it's CRASHED and will not load with a fatal error asking me to look at the log file.

6,500 lines of stuff.  All dated today.  That's the end of that editor which I paid good money for.

ARGH!

And before I installed the updates I did the Never thing to Preferences>ColdFusion>Profiles>Editor>Typing and it didn;t change anything.  Wonder how I get a refund from Adobe for such a POS editor?

Thanks for your reply, anyway   I'll try Sublime Text as I've heard from several people it's good.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2019 0
Community Beginner ,
Jun 13, 2019

Copy link to clipboard

Copied

So, installed Sublime ... got latest version ... 3.2.1 Build 3207.

Fired it up ... familiarizing myself with it.  Started typing ... and [ becomes [] ....etc.

Now looking in this editor to find where to turn off auto-complete ... cannot find it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2019 0
Adobe Community Professional ,
Jun 13, 2019

Copy link to clipboard

Copied

The crash will NOT have "lost" your code. It's there, wherever your you had told it to save it before updating. (And if you had NOT told it to save, then like any editor it would have asked you to save before exiting. And you surely didn't type 6500 lines of code and never save it, right?)

But I get it: even if you find the code, you are moving on from CFB. And I see your next question about sublime. I will leave that for others who use it to help you there.

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2019 0
Community Beginner ,
Jun 13, 2019

Copy link to clipboard

Copied

Misunderstanding!  When CFB crashed, it dumped a 64000 line log file! 

I lost nothing.  As with others Ctrl-S is used every minute or more!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2019 0
Adobe Community Professional ,
Jun 14, 2019

Copy link to clipboard

Copied

Yep, sorry. I see now I somehow misread your previous comment. As far as getting your money back, when did you buy and how much did you pay? (It's free with ColdFusion, so many don't pay for it at all.)

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2019 0
Community Beginner ,
Jun 15, 2019

Copy link to clipboard

Copied

Adobe are analysing the logs to see why it refuses to launch.

I bought CFB 2018 a couple of months ago but have had 2016 for a while.  Free you say?  Not for me.

$300.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2019 0
Adobe Community Professional ,
Jun 15, 2019

Copy link to clipboard

Copied

coder1957**  wrote

And before I installed the updates I did the Never thing to Preferences>ColdFusion>Profiles>Editor>Typing and it didn;t change anything. 

I think you should have changed the appropriate settings in the following menus:

    Preferences > ColdFusion > Profiles > Editor> Code Assist

    Preferences > ColdFusion > Profiles > Editor> Typing

After that you should have pressed Apply and restarted CF Builder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2019 0
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

I had to unintall CFB and reinstall.  Then after careful exam of all the menus (too many!) I got it working by doing what I should have done in the first place

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 1
Adobe Community Professional ,
Jun 25, 2019

Copy link to clipboard

Copied

Nice to hear. Could you please share with us how you got it to work?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 0
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

Had to go into both ColdFusion AND Javascript subsets of WIndow > Preferences. 

Then basically switch EVERYTHING off.

Does that simplify it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 0