Highlighted

IIS 10 Coldfusion 11 served website won't load default home page on IOS mobile devices

Community Beginner ,
Apr 27, 2017

Copy link to clipboard

Copied

Have a Windows 2016 server with IIS 10 running ColdFusion 11. Certain websites (with https://) won't load the default home page on iPhone and iPad only. The default home pages load great on all browsers on Windows 10, and even on a Mac in Safari and Chrome, but won't load on iPhone and iPad in either Safari or Chrome -- they just time out. If I put the name of the default page in the URL, it will load just fine on these IOS mobile devices, but if I just use the site's domain name, it will NOT load. IOS versions are up-to-date. If we set the default page to an html page it WILL load; if we set it to a cfm page it WILL NOT load.

So the FAILING situation is in loading default cfm page on iPhone or iPad.

I have come up with a workaround for this problem.

I created an index.html file containing:

<meta http-equiv="refresh" content="0;URL='https://domainname.com/index.cfm'" />

and made index.html the default page for the website.

I don't like it, but it seems to get things working on the iPad and iPhone.

Anyone have any suggestions?  Thanks!

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

IIS 10 Coldfusion 11 served website won't load default home page on IOS mobile devices

Community Beginner ,
Apr 27, 2017

Copy link to clipboard

Copied

Have a Windows 2016 server with IIS 10 running ColdFusion 11. Certain websites (with https://) won't load the default home page on iPhone and iPad only. The default home pages load great on all browsers on Windows 10, and even on a Mac in Safari and Chrome, but won't load on iPhone and iPad in either Safari or Chrome -- they just time out. If I put the name of the default page in the URL, it will load just fine on these IOS mobile devices, but if I just use the site's domain name, it will NOT load. IOS versions are up-to-date. If we set the default page to an html page it WILL load; if we set it to a cfm page it WILL NOT load.

So the FAILING situation is in loading default cfm page on iPhone or iPad.

I have come up with a workaround for this problem.

I created an index.html file containing:

<meta http-equiv="refresh" content="0;URL='https://domainname.com/index.cfm'" />

and made index.html the default page for the website.

I don't like it, but it seems to get things working on the iPad and iPhone.

Anyone have any suggestions?  Thanks!

Views

2.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 27, 2017 0
Community Beginner ,
Apr 29, 2017

Copy link to clipboard

Copied

This problem does not occur with IIS 6 on an earlier server operating system.  Only with IIS 10 on Windows Server 2016.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2017 0
Community Beginner ,
Aug 14, 2017

Copy link to clipboard

Copied

We are experiencing this too. We have IIS 10 and ColdFusion 2016. Any solutions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2017 1
Advocate ,
Aug 17, 2017

Copy link to clipboard

Copied

I think this is related to this bug:

https://tracker.adobe.com/#/view/CF-4198446

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2017 1
New Here ,
Oct 03, 2017

Copy link to clipboard

Copied

This is apparently a bug in Safari version 9 and newer.  Affects ColdFusion running on Windows Server 2016, but also other applications (reported by other developers of ASP, ASP.net and NGINX.)

Detailed here:

http://www.giancarlogomez.com/2016/05/coldfusion-iis-10-http2-safari-bug.html

https://tracker.adobe.com/#/view/CF-4198446

Temporary fix (disable http2 on Windows Server 2016 in the registry):

- Open the registry editor (regedit)

- Browse to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters

- Enter 2 new DWORD Values EnableHttp2Cleartext and EnableHttp2Tls

- Set their values to 0

- Reboot

Reference:

https://www.youtube.com/watch?v=a__h2EkbCb4

https://medium.com/@jason.mcclellan/nginx-safari-http2-not-working-607a8333e67a

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Community Beginner ,
Nov 16, 2017

Copy link to clipboard

Copied

I believe this was resolved with iOS 11. We had this issue but after upgrading to iOS 11, I could no longer reproduce this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2017 0