Highlighted

IIS Coldfusion

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Hello. I have updated Coldfusion 9 to 2018 on a Windows 2016 server with IIS 10 installed. For some reason I am now not able to access any of my pages. I get a 401.3 error. I have added IUSR, IIS_USR, Default App pool to the permissions of the folder of the page. Also I have enabled anonymous login as well and still get the 401.3 error. I am at a loss to what is different. 

TOPICS
Server administration

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

IIS Coldfusion

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Hello. I have updated Coldfusion 9 to 2018 on a Windows 2016 server with IIS 10 installed. For some reason I am now not able to access any of my pages. I get a 401.3 error. I have added IUSR, IIS_USR, Default App pool to the permissions of the folder of the page. Also I have enabled anonymous login as well and still get the 401.3 error. I am at a loss to what is different. 

TOPICS
Server administration

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 03, 2020 0
LEGEND ,
Mar 03, 2020

Copy link to clipboard

Copied

Standard first question when things go awry following an update from an old(er) version to a more recent version:  Did you remove the connector to the old(er) version and add the connector to the new version?

 

If yes, then it could be something in IIS.  If no, then that might be the problem.

 

As usual, this is a job for Charlie Arehart.  Dude seriously rocks when it comes to understanding installation issues.

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Yes I removed the connector and even uninstalled the old version and still nothing. The crazy thing is before the upgrade of Coldfusion to 2018 it works in IIS 10. As soon as I do the upgrade it stops like something doesnt have permissions to access a file. But i have no idea what. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
LEGEND ,
Mar 03, 2020

Copy link to clipboard

Copied

Are you running the installer with administrative privileges?  I mean as the admin account, not just "Run as administrator".

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Yes I am logged in as a server administrator and I did "run as admin" as well. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
Adobe Community Professional ,
Mar 03, 2020

Copy link to clipboard

Copied

First, Wolf, thanks for the kind regards. Second, lsmith, it could be anything.  And it may be impacted by things you have not told us.

 

First, are you saying that ALL you did was install CF2018 and then remove the CF9 connector from IIS and added the CF2018 one? Or did you ALSO make any changes to ANYTHING in IIS or in the files that it points to, as you struggled to get things working? If you did, then you could have introduced problems that we can't possibly foresee--and I realize you may not be able to recall what all changes you made.

 

But let's assume you will say, "no, I didn't change anything". Then the question would be why the site (now pointing to CF2018) would be reporting a 401.3 (unauthorized).

 

We will assume that the site in question is an existing site, that was working before with CF9. Is that right? So it's not like you had IIS "authentication" configured to require a login before, right? And you are browsing the site's URL in the same browser where you had browsed it before, when it was connected to CF9, right? (Again, if either of these is NOT true, then perhaps in creating your NEW site to use with CF2018, you did something different than how the site had been configured that pointed to CF9).

 

A next question is whether (when you used the CF2018 wsconfig tool), did you configure it for "all sites" or for this one site? That may not matter, but it may be useful to know.

 

I will say that there are so many things to be considered (in terms of what's there now, and what you may or may not have done), that honestly I think you'll find it hard to resolve this via back and forth like this. There's often just no substitute for having an experienced eye directly looking into things, which I can do via remote consulting--as can others. I list such folks at https://www.cf411.com/cftrouble (and I could be available this afternoon or any day this week, as that sort of help is what I do for a living, in addition to trying to help here when possible).

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi. I literally ran the CF 2018 installer and did the migration. The only thing that is different is that a 32 bit version of CF 9 was installed and I am installing a 64bit version of CF 2018. I believe to make it work in IIS you have to enable 32 bit application support by setting it to true. I disconnected the CF9 connector and reconnected with CF 2018. I tried selecting all the sites with the connector and I tried to select just 1 site but nothing seems to work. I am thinking it may be an IIS issue because there was Windows authentication that was on before but I turned it off and made it only anonymous to try to eliminate credentials being an issue and it still fails with the 401.3. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Adobe Community Professional ,
Mar 04, 2020

Copy link to clipboard

Copied

So did you change the 32-bit setting for the app pool, then?

 

Also, are you trying the failing page from a browser ON the server? You may get more detail and indeed a different error message on the server than off (due to an iis setting). 

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

I did change the app pool as well. I also am browsing from the server. That is where I am getting the error at. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Adobe Community Professional ,
Mar 04, 2020

Copy link to clipboard

Copied

I'm out of ready ideas. You can either wait to see if others have more, or again we can get together and may solve it quickly. Your satisfaction is guaranteed, btw: you won't pay for time you don't find valuable. 

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0