Highlighted

Install Coldfusion 11 on IIS 7 and see error 404.0 when I try to run servlet

New Here ,
Jan 15, 2015

Copy link to clipboard

Copied

I install Coldfusion 11 on IIS 7 and see error 404.0 when try to run servlet from "index.cfm". I added:

    .class in folder C:\ColdFusion11\wwwroot\WEB-INF\classes,

    servlets configuration in C:\ColdFusion11\wwwroot\WEB-INF\web.xml,

    .jar in C:\ColdFusion11\wwwroot\WEB-INF\lib,

    "index.cfm" in C:\inetpub\wwwroot,

Servlets are java classes. "index.cfm" is run, because it located in IIS home folder(C:\inetpub\wwwroot) and when I try to go to servlet from "index.cfm" i see error 404.0. Before I work on Coldfusion 9 and it's work perfectly, but I will need to use websockets and Coldfusion 9 not support its. In Coldfusion 9, when I install it, I check "Configure web server for Coldfusion 9 applications" if see "Error 404" and it's solve problem. In 11 version I not see checkbox "Configure web server for Coldfusion 11 applications". Maybe in this is my problem. Please help!

Views

397

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Install Coldfusion 11 on IIS 7 and see error 404.0 when I try to run servlet

New Here ,
Jan 15, 2015

Copy link to clipboard

Copied

I install Coldfusion 11 on IIS 7 and see error 404.0 when try to run servlet from "index.cfm". I added:

    .class in folder C:\ColdFusion11\wwwroot\WEB-INF\classes,

    servlets configuration in C:\ColdFusion11\wwwroot\WEB-INF\web.xml,

    .jar in C:\ColdFusion11\wwwroot\WEB-INF\lib,

    "index.cfm" in C:\inetpub\wwwroot,

Servlets are java classes. "index.cfm" is run, because it located in IIS home folder(C:\inetpub\wwwroot) and when I try to go to servlet from "index.cfm" i see error 404.0. Before I work on Coldfusion 9 and it's work perfectly, but I will need to use websockets and Coldfusion 9 not support its. In Coldfusion 9, when I install it, I check "Configure web server for Coldfusion 9 applications" if see "Error 404" and it's solve problem. In 11 version I not see checkbox "Configure web server for Coldfusion 11 applications". Maybe in this is my problem. Please help!

Views

398

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 15, 2015 0
Enthusiast ,
Jan 16, 2015

Copy link to clipboard

Copied

share the web.xml as the same is working for me in CF 9 and CF 11

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2015 0
New Here ,
Jan 16, 2015

Copy link to clipboard

Copied

Where this web.xml is locate?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2015 0