Highlighted

Invalid object name on everyday

New Here ,
Feb 23, 2017

Copy link to clipboard

Copied

Dear All.,

My CF website is going down daily at a particular time in evening and the log is detailing that 'Error Executing Database Query. [Macromedia][SQLServer JDBC Driver][SQLServer]Invalid object name 'XYZ'.'

I can solve this by going to CFADMIN >> Data source >> Edit the Password (or doing any other edits) to the datasource and the site will be back.

I am having 10 datasources and this is happening to a particular datasource and not to all.

Please let me know what is the reason for this down, particularly for a datasource, and tables inside the datasource came as invalid object name.

Views

466

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Invalid object name on everyday

New Here ,
Feb 23, 2017

Copy link to clipboard

Copied

Dear All.,

My CF website is going down daily at a particular time in evening and the log is detailing that 'Error Executing Database Query. [Macromedia][SQLServer JDBC Driver][SQLServer]Invalid object name 'XYZ'.'

I can solve this by going to CFADMIN >> Data source >> Edit the Password (or doing any other edits) to the datasource and the site will be back.

I am having 10 datasources and this is happening to a particular datasource and not to all.

Please let me know what is the reason for this down, particularly for a datasource, and tables inside the datasource came as invalid object name.

Views

467

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 23, 2017 0
Advocate ,
Feb 24, 2017

Copy link to clipboard

Copied

I would say this is an issue with the SQL server rather then CF. Have you tried using a different user for the datasource to see if the issue still happens?

If its the same time everyday, I would look at maintenance tasks on the SQL server to see if they are doing something that causes this kind of behaviour.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2017 2
New Here ,
Feb 24, 2017

Copy link to clipboard

Copied

Need to check the jobs.

Also the default user name for the database was set... The other one which is running well is not having the default user name

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2017 0
New Here ,
Mar 02, 2017

Copy link to clipboard

Copied

Dear All.,

The original reason is there is a job in our site which is reassigning the datasource and thus caused this. Now the problem is solved....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2017 0
BKBK LATEST
Adobe Community Professional ,
Mar 03, 2017

Copy link to clipboard

Copied

Please mark the correct answer. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2017 0