Highlighted

Issue with Coldfusion Webservice. Unable to handle multiple requests from external system.

New Here ,
Nov 23, 2015

Copy link to clipboard

Copied

We have a webservice component developed in Coldfusion to handle a data feed from an external system.  External system is a java environment feeding data to our application through the webservice component.  When a bunch of messages are submitted ColdFusion handles few messages and rejects remaining messages in the server level(like 3 out of 10.  There is no patter we could capture with this connection.  Message counts are random.).  ColdFusion Server runs on IIS.  ColdFusion does not throw an error message to the external system for the unprocessed messages.   I am not sure if this is an issue with IIS or ColdFusion server.

Any help would be much appriciated!

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Issue with Coldfusion Webservice. Unable to handle multiple requests from external system.

New Here ,
Nov 23, 2015

Copy link to clipboard

Copied

We have a webservice component developed in Coldfusion to handle a data feed from an external system.  External system is a java environment feeding data to our application through the webservice component.  When a bunch of messages are submitted ColdFusion handles few messages and rejects remaining messages in the server level(like 3 out of 10.  There is no patter we could capture with this connection.  Message counts are random.).  ColdFusion Server runs on IIS.  ColdFusion does not throw an error message to the external system for the unprocessed messages.   I am not sure if this is an issue with IIS or ColdFusion server.

Any help would be much appriciated!

Views

232

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 23, 2015 0
Adobe Community Professional ,
Nov 23, 2015

Copy link to clipboard

Copied

Well, the problem could be in the web server connector (IIS to CF), especially if you’re on CF10 or 11, where THAT may be keeping all requests from always running.

That would NOT result in any logged error in CF, if that’s what you mean by “ColdFusion does not thrown an error”. Or do you mean that the caller never gets any error at all, when this problem happens? If they DO get an error, you may see that it’s from IIS (even if you don’t see it tracked in CF’s logs).

As for why the connector could be blocking requests, that’s not uncommon in CF10 or 11, under certain circumstances. The first problem is that the connector may be outdated. Many miss the fact that thought they update CF 10 or 11, most updates call for you to update the connector. If you don’t update it, you could experience due to bugs that have since been resolved. For more on this, see my post:

http://www.carehart.org/blog/client/index.cfm/2013/9/13/why_you_must_update_cf10_webserver_connector

Second, it may be that you may need to tune the connector. For more on that, see Adobe’s post:

http://blogs.coldfusion.com/post.cfm/coldfusion-11-iis-connector-tuning

If you can’t resolve it, there are folks (including myself) who offer remote troubleshooting assistance. I offer a list of them as a category of the CF411 of my site, carehart.org/cf411/#cfconsult.

/charlie

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2015 0