“libCFXNeo.jnilib” cannot be opened because the developer cannot be verified.

New Here ,
Nov 13, 2020 Nov 13, 2020

Copy link to clipboard

Copied

When installing 2021 on macOSX Big Sur throws error, 

 

“libCFXNeo.jnilib” cannot be opened because the developer cannot be verified.

 

This appears to be a notorization issue with Apple.  This happens with every mouse click.  My guess is the dev team used a forged certificate, which is common, and a full notorization needs to be approved by Apple.

 

Or maybe I should shut my mouth.

 

Views

184

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2020 Nov 13, 2020

Copy link to clipboard

Copied

Actually, it installed.  But navigating in CFIDE/Administrator it throws that error everytime you trapse around the navigation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I don't have a solution, but I do have an observation, and as much for others who may find this thread. FWIW, CF2021 was only updated to support Catalina (10.15), per the system requirements for CF.

 

And as Big Sur was only released publicly only on Nov 12, while CF2021 was released on the 10th, perhaps the CF team could be forgiven for not yet having added that support. 🙂 And to be clear, they don't tend to "jump on" new releases. It could be months before they would add support for it.

 

But given the severity of this problem, perhaps they will for this version. Or maybe someone will help identify a workaround in the meantime. But if nothing else, register your concern with cfinstal@adobe.com (and I would recommend you acknowledge that it's not yet supported, but are asking if they are working on it).

 

Do let us know if you may learn anything new.


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

LATEST

Thanks Charlie.

Right now Apple is blaming it on a certificate server on their end.  But I did manage to fix it.

 

When you get the error, " “libCFXNeo.jnilib” cannot be opened because the developer cannot be verified."

go to: APPLE>System Preferences>System & Security

You'll get this dialog box [see below] and a warning near the bottom of the box saying: "“libCFXNeo.jnilib” cannot be opened because the developer cannot be verified."wants to execute." Click allow and it is fixed.

 

Sorry I don't have the actual picture, once I fixed it I couldn't unfix it.  This evidently was in a service pack release in the last 2 days.

 

Enjoy!

 

Screen Shot 2020-11-18 at 7.08.43 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines