Licence reverted to Developer following ColdFusion Application Server service restart

New Here ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

We were having a number of issues with our database connections (turned out to be a database issue) so did a ColdFusion Application Server service restart just in case that helped.

The licence then went back to Developer.

 

Re-entered the Standard licence key and all is well.

But need to understand why this happened.  Running ColdFusion 2018. Never occurred on our old ColdFusion 10. 

Concerned if it happens out of hours - eg. a server reboot or someone else restarts the service, as this used to be a standard way of getting ColdFusion working it if hangs.

 

Thanks 

 

Paul

 

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2021 May 01, 2021

Copy link to clipboard

Copied

LATEST

Good question, @paul_durrant . Though you never observed the issue on ColdFusion 10, I can assure you the problem was known in earlier ColdFusion versions. For example, in ColdFusion 8.

 

One likely cause is known. During restart ColdFusion - for some reason you have to look into - was unable to get access to or read the file /lib/license.properties. As a result, ColdFusion defaulted to the Developer license.

 

Check your log files. You might find clues there as to what prevented ColdFusion from reading the license file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines