Highlighted

Mac 10.10.2 Yosemite Security Update 2015-003 ColdFusion 11 doesn't start - WHY?

New Here ,
Mar 21, 2015

Copy link to clipboard

Copied

I'm using Mac (OS X 10.10.2 Yosemite) and the Apache with CF 11 for developing. After installing the new Apple Security Update 2015-003 ColdFusion stops working? What can I do? What are the reasons?

Views

753

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mac 10.10.2 Yosemite Security Update 2015-003 ColdFusion 11 doesn't start - WHY?

New Here ,
Mar 21, 2015

Copy link to clipboard

Copied

I'm using Mac (OS X 10.10.2 Yosemite) and the Apache with CF 11 for developing. After installing the new Apple Security Update 2015-003 ColdFusion stops working? What can I do? What are the reasons?

Views

754

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 21, 2015 0
New Here ,
Mar 21, 2015

Copy link to clipboard

Copied

The problem was using the option Use J2EE session variables (Server Settings > Memory Variables) in the administrator. Turn it off and all problems are gone. Solved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2015 0
Advocate ,
Mar 21, 2015

Copy link to clipboard

Copied

I wouldn't really call that a solution. J2EE sessions are important and improve session security as well as a number of other improvements. I cant really see why this option would cause ColdFusion to stop working either, but as you haven't given any errors or explanations of the problem you get, I can't suggest the correct resolution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2015 0
New Here ,
Mar 21, 2015

Copy link to clipboard

Copied

You are right. But the solution is OK for me.

But now for all: The problem is (on MAC OS 10.10) turning the option Use J2EE session variables (Server Settings > Memory Variables) in the administrator to on, the ColdFusion 11 Server dosen't restart correctly. It hangs.

I can only access the administrator again (for turning the option off), if I kill the file /applications/ColdFusion11/cfusion/runtime/work/Catalina/localhost/tmp/_axis2/sessions.ser .

After restarting the CF11 server everything is OK (without the option Use J2EE session variables).

And my question again (but now not urgent): Why?

Jens

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2015 0
haxtbh LATEST
Advocate ,
Mar 21, 2015

Copy link to clipboard

Copied

Don't have my Macbook with me at the moment to test but will try later.

I would recommend submitting a bug in case its something Adobe need to fix and are not aware of - https://bugbase.adobe.com/index.cfm?event=newBug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2015 0