Highlighted

Mac OSX 10.9.4 coldfusion 11 standalone server ERROR: HTTP Status 500 - java.lang.NullPointerException

New Here ,
Sep 15, 2014

Copy link to clipboard

Copied

Hi all.

I have installed the cold fusion server.

at first with mac server, apache..... but after install cold fusion and want to go to the admin page:

HTTP Status 500 - java.lang.NullPointerException

I deinstalled the server from mac and cold fusion..

after a fresh install of coldfusion 11 and use the build in server..

the same error..

does anybody knows the problems?

I Use Java 7 Update 67

A friend of me have installed it .. it runs

greetings thorsten

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mac OSX 10.9.4 coldfusion 11 standalone server ERROR: HTTP Status 500 - java.lang.NullPointerException

New Here ,
Sep 15, 2014

Copy link to clipboard

Copied

Hi all.

I have installed the cold fusion server.

at first with mac server, apache..... but after install cold fusion and want to go to the admin page:

HTTP Status 500 - java.lang.NullPointerException

I deinstalled the server from mac and cold fusion..

after a fresh install of coldfusion 11 and use the build in server..

the same error..

does anybody knows the problems?

I Use Java 7 Update 67

A friend of me have installed it .. it runs

greetings thorsten

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 15, 2014 0
Adobe Employee ,
Sep 15, 2014

Copy link to clipboard

Copied

Hi,

Can you please share the error log, it seems like you have to add the machine name in hosts file. However if you can share the error log that will give more information to resolve this.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2014 0
New Here ,
Sep 15, 2014

Copy link to clipboard

Copied

Hi this is my cold fusion Error LOG

java.lang.NullPointerException

  at coldfusion.CfmServlet.init(CfmServlet.java:97)

  at coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:121)

  at coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59)

  at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1279)

  at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1192)

  at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:864)

  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:134)

  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)

  at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501)

  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)

  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)

  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)

  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422)

  at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1040)

  at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607)

  at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:313)

  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

  at java.lang.Thread.run(Thread.java:745)

Sep 16, 2014 8:30:59 AM org.apache.catalina.core.ApplicationContext log

INFO: failed to load: coldfusion.CfmServlet

Sep 16, 2014 8:30:59 AM org.apache.catalina.core.StandardWrapperValve invoke

SEVERE: Allocate exception for servlet CfmServlet

java.lang.NullPointerException

  at coldfusion.CfmServlet.init(CfmServlet.java:97)

  at coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:121)

  at coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59)

  at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1279)

  at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1192)

  at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:864)

  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:134)

  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)

  at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501)

  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)

  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)

  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)

  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422)

  at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1040)

  at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607)

  at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:313)

  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

  at java.lang.Thread.run(Thread.java:745)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2014 0
New Here ,
Sep 15, 2014

Copy link to clipboard

Copied

HTTP Status 500 - java.lang.NullPointerException


type Exception report

message java.lang.NullPointerException

description The server encountered an internal error that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: java.lang.NullPointerException coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:129) coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422) org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1040) org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607) org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:313) java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) java.lang.Thread.run(Thread.java:745) 

root cause

java.lang.NullPointerException coldfusion.CfmServlet.init(CfmServlet.java:97) coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:121) coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422) org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1040) org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607) org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:313) java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) java.lang.Thread.run(Thread.java:745) 

note The full stack trace of the root cause is available in the Apache Tomcat/7.0.52 logs.


Apache Tomcat/7.0.52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2014 0
New Here ,
Sep 15, 2014

Copy link to clipboard

Copied

But where is the tomcat log file ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2014 0
Explorer ,
Sep 16, 2014

Copy link to clipboard

Copied

senkel,

Can you try to point CF to the default Java, and see if it starts up.

You can edit the jvm.config file at <cf_root>/cfusion/bin and point the java.home setting to the default location at <cf_root>/cfusion/jre.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2014 0
New Here ,
Sep 16, 2014

Copy link to clipboard

Copied

Hinayak

in my cold fusion folders are not a jre folder..

i unzip now ire.zip and copy the folder in cold fusion..

but now :

The ColdFusion 11 server is starting up and will be available shortly.

There has been an error starting ColdFusion 11 server, please check the logs.

i can't find something in the logs

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2014 0
New Here ,
Sep 16, 2014

Copy link to clipboard

Copied

I deinstall the server and install new..

all folders are now there ...

and the java path:

java.home=../../jre/Contents/Home/jre

but the server won't start again

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2014 0
Explorer ,
Sep 16, 2014

Copy link to clipboard

Copied

I don't think with the default installation "<cf_root>/jre/Contents/Home/jre" exists. There should be no "jre" in "Home" . Can you check if that directory physically exists there.

The path should be set to "../../jre/Contents/Home

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2014 0
Adobe Employee ,
Sep 16, 2014

Copy link to clipboard

Copied

Hi,

Can you please send an email at cf.install@adobe.com

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2014 0
New Here ,
Nov 10, 2014

Copy link to clipboard

Copied

I have exactly same issue. What is the solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2014 0
Community Beginner ,
Nov 10, 2014

Copy link to clipboard

Copied

Hi,

Couple of our team members blogged about a resolution for this issue. I am attaching the same here:

http://blogs.coldfusion.com/post.cfm/coldfusion-server-starting-with-unable-to-initialise-service-ex...

http://blog.immanuelnoel.com/2014/06/06/fixing-the-null-pointer-exception-on-coldfusion

Let us know if this helps.

Thanks,

Priyatharsini

Adobe ColdFusion Team.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2014 1
New Here ,
Nov 18, 2014

Copy link to clipboard

Copied

These two solutions don't work for me. My situation is right after install the coldfusion, the localhost server works fine. But when I reboot the computer next day, the server show up the the NullPointerException.  What I found saying that the coldfusion server is start right the way when boot the computer, but the Tomcat is not. So my solution is


1. Delay coldfusion server  at the startup item of mac.

or

2. Restart coldfusion server every time after reboot computer.

Mac Temrminal:

./Coldfusion restart

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2014 0
Community Beginner ,
Nov 20, 2014

Copy link to clipboard

Copied

Hi,

Can you please let us know the following information:

1. Any Web Server is configured with CF? If yes Web Server details with exact version.

2. Please attach the logs.

Thanks,

Priyatharsini

Adobe ColdFusion Team.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 20, 2014 0