Highlighted

Paypal Instant Pay Notification is doubling URL when sent

New Here ,
Sep 05, 2014

Copy link to clipboard

Copied

For months now, I have not been able to get any help out of Paypal. When a product is purchased, I have IPN set to on.IN the selling tools section, the following URL is used to return the IPN info:

Paypal IPN settings

Notification URL    http://www.heritageseminary.com/paypal/ipn/ipn.cfm

Below is my config setup sent to payppal.

config.cfm

<cfset paypal["notify_url"]="http://www.heritageseminary.com/paypal/ipn/ipn.cfm">

When a payment is made, I receive the  I am receiving the following error:

Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

This is the URL that paypal is trying to connect with.

http://www.heritagesemianary.com/http://www.heritageseminary.com/paypal/ipn/ipn.cfm

When I check the IPN history, the status shows still trying.

When I click Message ID, I get the following address:

Notification URL http://www.heritagesemianary.com/http://www.heritageseminary.com/paypal/ipn/ipn.cfm

Any idea as to where I should be looking?

Adobe Community Professional
Correct answer by BKBK | Adobe Community Professional

The config setting should perhaps be the relative path:

<cfset paypal["notify_url"]="paypal/ipn/ipn.cfm">

Views

251

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Paypal Instant Pay Notification is doubling URL when sent

New Here ,
Sep 05, 2014

Copy link to clipboard

Copied

For months now, I have not been able to get any help out of Paypal. When a product is purchased, I have IPN set to on.IN the selling tools section, the following URL is used to return the IPN info:

Paypal IPN settings

Notification URL    http://www.heritageseminary.com/paypal/ipn/ipn.cfm

Below is my config setup sent to payppal.

config.cfm

<cfset paypal["notify_url"]="http://www.heritageseminary.com/paypal/ipn/ipn.cfm">

When a payment is made, I receive the  I am receiving the following error:

Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

This is the URL that paypal is trying to connect with.

http://www.heritagesemianary.com/http://www.heritageseminary.com/paypal/ipn/ipn.cfm

When I check the IPN history, the status shows still trying.

When I click Message ID, I get the following address:

Notification URL http://www.heritagesemianary.com/http://www.heritageseminary.com/paypal/ipn/ipn.cfm

Any idea as to where I should be looking?

Adobe Community Professional
Correct answer by BKBK | Adobe Community Professional

The config setting should perhaps be the relative path:

<cfset paypal["notify_url"]="paypal/ipn/ipn.cfm">

Views

252

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 05, 2014 0
Adobe Community Professional ,
Sep 06, 2014

Copy link to clipboard

Copied

The config setting should perhaps be the relative path:

<cfset paypal["notify_url"]="paypal/ipn/ipn.cfm">

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2014 0
New Here ,
Sep 06, 2014

Copy link to clipboard

Copied

Thanks BKBK, solved the issue. Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2014 0