Problem with cfhtmltopdf and special characters

New Here ,
Apr 15, 2016 Apr 15, 2016

Copy link to clipboard

Copied

How can I fix cfhtmltopdf showing "?" for special characters "1/2", "3/4", "•"? We have ColdFusion Server Standard 11,0,07,296330 installed.

Views

438

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Apr 18, 2016 Apr 18, 2016
After further research and discussed with our DBA/system admin, we suspected it had to do the CF11 server JVM setting. We added "-Dfile.encoding=utf8" to java.args in jvm.config and the special characters displayed correctly.

Likes

Translate

Translate
Engaged ,
Apr 18, 2016 Apr 18, 2016

Copy link to clipboard

Copied

Could you please provide a stripped-down version of the HTML containing header with doctype, CSS font embeds and HTML used to generate the characters?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2016 Apr 18, 2016

Copy link to clipboard

Copied

LATEST

After further research and discussed with our DBA/system admin, we suspected it had to do the CF11 server JVM setting. We added "-Dfile.encoding=utf8" to java.args in jvm.config and the special characters displayed correctly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines