Highlighted

Question About CFFormGateway

New Here ,
Nov 17, 2015

Copy link to clipboard

Copied

I'm testing an upgrade to CF11.  Everything is working except my flash form.  When I check the web.xml file, the CFFormGateway servlet mapping is commented out as well as the CFFormGateway filter-mapping.  The CFFormGateway servlet description indicates that this servlet "allows flash forms to connect to CFML and CFC templates".

I found references to a possible work-around created by Josh Koop with the HouseofFusion but can't find details about that possible solution; especially since HoF is defunct.

I've checked and verified the necessary .js, .cfm, and .swc files are in the CFIDE directory.  I've also verified there is a specified height and width indicated within the cfform tag.

Will un-commenting the CFFormGateway servlet and filter resolve this issue with the cfform format="flash"?

The pages render but a 404 error - file or directory not found - message is what is actually being displayed.

Under the current version, the cfform successfully renders.

TOPICS
Flash integration

Views

785

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Question About CFFormGateway

New Here ,
Nov 17, 2015

Copy link to clipboard

Copied

I'm testing an upgrade to CF11.  Everything is working except my flash form.  When I check the web.xml file, the CFFormGateway servlet mapping is commented out as well as the CFFormGateway filter-mapping.  The CFFormGateway servlet description indicates that this servlet "allows flash forms to connect to CFML and CFC templates".

I found references to a possible work-around created by Josh Koop with the HouseofFusion but can't find details about that possible solution; especially since HoF is defunct.

I've checked and verified the necessary .js, .cfm, and .swc files are in the CFIDE directory.  I've also verified there is a specified height and width indicated within the cfform tag.

Will un-commenting the CFFormGateway servlet and filter resolve this issue with the cfform format="flash"?

The pages render but a 404 error - file or directory not found - message is what is actually being displayed.

Under the current version, the cfform successfully renders.

TOPICS
Flash integration

Views

786

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 17, 2015 0
BKBK LATEST
Adobe Community Professional ,
Dec 12, 2015

Copy link to clipboard

Copied

Sorry about the late response; I have only just seen your thread.

programmherT wrote:

I'm testing an upgrade to CF11.  Everything is working except my flash form.  When I check the web.xml file, the CFFormGateway servlet mapping is commented out as well as the CFFormGateway filter-mapping.  The CFFormGateway servlet description indicates that this servlet "allows flash forms to connect to CFML and CFC templates".

Someone must have commented them out. In a default ColdFusion 11 installation, they are not commented out.

I've checked and verified the necessary .js, .cfm, and .swc files are in the CFIDE directory.  I've also verified there is a specified height and width indicated within the cfform tag.

Will un-commenting the CFFormGateway servlet and filter resolve this issue with the cfform format="flash"?

I suspect uncommenting the CFFormGateway settings will resolve the issue. There is only one way to find out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 12, 2015 0