RDS "For input string" Error

Explorer ,
Apr 15, 2015 Apr 15, 2015

Copy link to clipboard

Copied

I have ColdFusion 11 U4 running as a Amazon EC2 instance from Adobe's Windows AMI.

I am trying to connect via ColdFusion Builder 3 (mine) and ColdFusion Studio (client's). At first I got the dreaded 404 error, so I added in /CFIDE/main/ide.cfm as an empty file so IIS would find it.

Now the error has changed to: 'Unable to contact the RDS Server... For input string: ""' in CF Builder.

In ColdFusion Studio the error was "server operation failure". After debugging was turned off it changed to "unhandled error, use logging enabled clients if possible."

I had HTTP filter restrictions in place for CFIDE directory stuff, but removed all that, no change. I have also tried all three options for user authentication for RDS.

I also tried it on my local machine but after I resolved the 404 error I get a 405 error for method not allowed. So that's no help either.

Here's the settings:

Description: {client name}

Host name: {IP Address}

Port Number: 80

Timeout: 30s

Context Root: empty

User Name: {user name}

Password: {password}

Thanks in advance.

TOPICS
Builder

Views

775

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 16, 2015 Apr 16, 2015

Copy link to clipboard

Copied

CFJSGeek, to be clear, the “method not allowed” is actually a GOOD thing. It confirms that, in that dev environment at least, your browser WAS able to get to RDS, but it’s setup to not allow a GET (which is what your browser sends by default). Are you saying you proceeded to setup CFB or CFS to point to that dev environment and it still didn’t work? Or did you misinterpret that message in your browser and stop there?

As for your other environment, let me say first that you do NOT need to add an empty CFIDE/main/ide.cfm. Instead, that request gets processed by CF as a servlet filter. There is no need for that file to exist.

That said, yes if you block the CFIDE folder (in IIS, for instance, if that’s what you mean by “http filter”), then yes it would fail.

And it shouldn’t matter whether debugging is on or not. As for the message you get when you say you turned it off, “unhandled error, use logging enabled clients if possible”, that’s one I never heard of, and I’ve been using the RDS feature (and helping people use it) for over 15 years, in CFS, HS, DW, and CFB. But I do see in googling that message that an old JRun Studio FAQ (it was an off-shoot of CFS) indicates that could happen if you have an invalid password.

Do you have the CF admin RDS security settings to “single password”, “separate username and password”, or “no password” (the latter would be dangerous on any public server, but of course having RDS at all on a public server would be worrisome). Are you positive you’re using the password defined there in the configuration of RDS in HS? Also, you mention using a username and password, which presumes then you need to have changed to “separate username and password”, and defined such a user in the “user manager” page of the CF Admin. You also need to give that user RDS access there, of course.

Can you confirm all these things, and we can try to go from there?

/charlie


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 20, 2015 Apr 20, 2015

Copy link to clipboard

Copied

Thanks for the response Charlie. Right now I'm going to focus on the ColdFusion Studio environment issue.

I added the blank CFIDE/main/ide.cfm file because otherwise it would give me a 404 error. I know you can also set IIS to not check is a file exists, but I opted for this solution. If there is a better fix for this I'm all ears.

I will have the guy double check his password again. I've been trying "separate username and password" with him but I'll give "single password" a shot. I'm wonder if because CFS is so old that it didn't support separate logins.

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

I know this is an old issue, but do you recall if you were able to solve this? I'm running into the "for input string" issue now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

LATEST

@CFJSGeekOmaha , I have responded to the same question in a different thread. The likely cause of the error is that, in the RDS settings:

 

  • you left an input field empty where you had to enter a value, typically an integer, or
  • you entered a value with the wrong datatype, for example, a string where an integer is required. Timeout should be an integer, hence 30 rather than 30s.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines