Highlighted

REST Services on Mac not working

New Here ,
Aug 25, 2014

Copy link to clipboard

Copied

I finally got my Mac 10.7 setup with CF 10 and Apache using multiple virtual hosts. I'm now trying to get my first REST service up and running but not having much luck.

I solved my 500 server errors and the 404 issues. Now I have a service registered. Problem is when I call the service it writes this to the application log.

"Component crude could not be found.Check if the path is correct or the application has been registered succesfully. The specific sequence of files included or processed is: '''' "

When I access it using cfhttp it returns a status code 200 but the filecontent is empty. When I access the service using my browser I get a status code of 200 but nothing returned.

Any suggestions on what could be going on?

Rest service mapping in CF Admin

Root path: /Users/myaccount/Documents/AdobeColdFusionBuilderworkspace/00localDev

Service mapping: restapp

Application.cfc app name is restapp

<cfset This.name = 'restapp'>

My file calling the rest service.

<cfhttp url="http://testapp:8500/rest/restapp/crudservice" result="restResult" method="GET" />

<cfdump var="#restResult#">

My rest cfc

<cfcomponent restpath="crudservice" rest="true">

    <cffunction name="sayHI" access="remote" httpmethod="GET" returntype="string" produces="text/plain">

        <cfreturn "hello world">

    </cffunction>

</cfcomponent>

Views

126

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

REST Services on Mac not working

New Here ,
Aug 25, 2014

Copy link to clipboard

Copied

I finally got my Mac 10.7 setup with CF 10 and Apache using multiple virtual hosts. I'm now trying to get my first REST service up and running but not having much luck.

I solved my 500 server errors and the 404 issues. Now I have a service registered. Problem is when I call the service it writes this to the application log.

"Component crude could not be found.Check if the path is correct or the application has been registered succesfully. The specific sequence of files included or processed is: '''' "

When I access it using cfhttp it returns a status code 200 but the filecontent is empty. When I access the service using my browser I get a status code of 200 but nothing returned.

Any suggestions on what could be going on?

Rest service mapping in CF Admin

Root path: /Users/myaccount/Documents/AdobeColdFusionBuilderworkspace/00localDev

Service mapping: restapp

Application.cfc app name is restapp

<cfset This.name = 'restapp'>

My file calling the rest service.

<cfhttp url="http://testapp:8500/rest/restapp/crudservice" result="restResult" method="GET" />

<cfdump var="#restResult#">

My rest cfc

<cfcomponent restpath="crudservice" rest="true">

    <cffunction name="sayHI" access="remote" httpmethod="GET" returntype="string" produces="text/plain">

        <cfreturn "hello world">

    </cffunction>

</cfcomponent>

Views

127

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2014 0

Have something to add?

Join the conversation